Comodo doesn't block terminating processes with SPT 12 method

Tested on Win XP SP3 with CFP 3.0.25 and 3.5 beta.
Here is it:
http://dl1.syssafety.com/download/spt.exe?pid=141

Since this is a vulnerability research board I’ll post a workaround

Under Defense+ Tasks > Common Tasks >My Protected COM Interfaces
Click Groups… button
Select Pseudo COM Interfaces - Important Ports and then click Add button → Com Components…
Paste \RPC Control\IcaApi in the Add new item field and then click the + button

Then Apply.

PS: please post about this SPT test in COMODO Internet Security 3.5 BETA Bug Reports

Tried it on Vista 64 and Comodo blocked terminating the process without need of adding the COM interface to protected ones like you explained.
Will try it on XP later this day but nevertheless I’ll do what you adviced me to.

It looks like this termination method need Terminal Services to be enabled.
I guess that UAC could affect it on Vista machines Password protect or hide folders with Folder Guard software .

I got UAC disabled, I rather use Comodo :■■■■
I tried it with the CFP version of CIS, I expresses myself a bit unclearly.