Comodo Does not have an Icon in Programs and Features [MN] [v6]

If you look under Programs and Features/Uninstall Programs. Comodo does not have its icon, yet has the default exe icon.

A. THE BUG/ISSUE:

  1. What you did: Looked in Programs and Features and saw Comodo did not have an icon
  2. What actually happened or you actually saw: Same as Above
  3. What you expected to happen or see: For comodo to have its Icon
  4. How you tried to fix it & what happened: N/A
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?: Yes
  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware): N/A
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Go Control Panel- Programs and Features/ Or, Control Panel- Programs- Uninstall a program.
  8. Any other information (eg your guess regarding the cause, with reasons): N/A

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): In Attachments

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: In attachments
  2. Screenshots illustrating the bug: In Attachments
  3. Screenshots of related CIS event logs: N/A
  4. A CIS config report or file: N/A
  5. Crash or freeze dump file: N/A
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: In attachments

C. YOUR SETUP:

  1. CIS version, AV database version & configuration: In attachments
  2. a) Have you updated (without uninstall) from a previous version of CIS: No
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): N/A
  5. Defense+, Sandbox, Firewall & AV security levels: Default- Internet Security with Cloud and Heuristics turned up.
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7 64bit, No SP1, UAC Off, Admin.
  7. Other security and utility software currently installed: Malwarebytes Scanner
  8. Other security software previously installed at any time since Windows was last installed: N/A
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: No

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again

Mouse

Fixed in 2708

[attachment deleted by admin]

Not fixed on my end, I noticed it says 21/12/2012 yet I installed the new version when it came out. See Picture

weird maybe a clean install would help. that is how i always install on my computer. Did you upgrade through the GUI?

Yes I installed it through the GUI.
I guess now that is a new bug. Updating Comodo doesn’t updates its name in Programs and Features, unless you Uninstall and Install.

Old bug maybe. If you click has version been updated?

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

I still have yet to complete re-install Comodo, but when updating through the program updates. It still does not update in Programs and Features.
My Comodo in programs and features still says its on version 6.0.64131.2674, from the 21/12/2012. How ever Comodo is running the latest version, 6.1.76867.2813

This problem still exists if updating through the Program update it self, but if you do a clean install, according to my friend it now has the icon.

Thanks very much for the update

Could you please do a bug report for the version update problem, which is more serious (it can confuse corporate config management tools)

Leaving open

Best wishes

Please try reinstalling CIS by following the methods I recommend in this post and see if it fixes this icon bug. I believe this is probably a bug which has carried over from earlier versions, but which a clean install would solve.

Please let me know if a reinstall fixes it so that I can move this to Resolved. If it doesn’t I will add this bug to the tracker.

Thank you. PM sent.

Re installing the program fixes the issue with Comodo under programs and features not showing correctly.
However I’m unsure if you update through in the program if it updates under programs and features, as I’ve not had the chance to test it.

To me this seems like there was a bug in a previous version which caused the icon problem. Then, the updater did not fix it in later versions, even though your reinstallation seems to show that the bug has been fixed.

Thus, it appears that the main bug is fixed, although it’s less clear why updating through the program wouldn’t fix the problem. Regardless, I will move this to Resolved as the main bug appears to be fixed.

Thank you.