Comodo does not detect applications.

Please help me! I downloaded v3 of the firewall on the day it was released and everything was fine till I updated it to the current version (

Now, the firewall is unable to detect any connections to the internet. For instance, when I launch a program like Internet Explorer, no alert popup appears. Now, all programs are able to access the internet and they are not being registered in the “Network Security Policy” list.

I therefore tried manually adding applications like “iexplorer.exe” to the “Network Security Policy” list and using the predefined “block application” policy to block “iexplorer”'s access to the internet; it does not work, internet explorer is still able to access the internet. The same goes for ALL applications. My computer is open to the internet even with CFP installed. It is like not having a firewall at all.

This happens even when I’m on custom policy mode. I tried reinstalling the firewall multiple times, and even did a installation on a clean WinVista OS to noavil. A check on the view active connections yields a couple windows service programs like svchost.exe, services.exe etc. (All register 0 bytes in and out).

I’m very disappointed with the current release. I’ve tried possible means that I could think of to solve this. I’m gussing that there is a conflict with the windows updates released last week. I’ve searched through the forums but have not found a similar post. If anybody is experiencing similar problems, please post! I would be forced to change to another firewall, if I can’t get this problem fixed very soon.

Please post the screenshots of your Application and Global Rules.

I’ve deleted every application rule during my attempt to figure a solution to the problem. And amazingly, CPF lets every single application through. It never happened before in versions 2x and 3x (piror to

As for Global rules, I’ve used the default stealth wizzard settings for p2p i.e (block all icmp in/out).

I’m on Custom Policy Mode but the firewall still manages to block all traffic when i turn it to block all traffic mode.