Comodo DNS settings seem to be irreversible. Please help.

I’m having problems with Comodo DNS servers. I used to use Comodo Dragon with DNS enabled and everything worked fine until I decided to use the latest CIS suite. Since then, I’ve encountered nothing but problems with several aspects of the suite.

Anyway, the problem I’m having right now with the DNS section, is I have enabled them through the router software AND through Windows control panel. I saved these settings and then went about surfing the internet. The first thing I noticed was that it would let me go to (a banking page in the UK) but as soon as I clicked ‘login’ to my account, I couldn’t go any further. Comodo must have blocked it because all my settings for everything else on the PC was just the same. The other thing I noticed Comodo DNS blocked was the updating section of Peerblock.

I went back to getting rid of Comodo DNS server settings and back to the original ISP ones I had when everything worked. There was still NO change! I have done this several times but it just isn’t working like it should be. If I knew this was going to happen, I wouldn’t have bothered changing them.

These changes were also made on a clean install of Windows.

I would like some help please.

Thank you.

I think the prob is coz of Comodo DNS.

Internet Explorer opens the login page fine.

Comodo Dragon with Comodo DNS enabled gives page cannot be displayed.

Comodo Dragon with Comodo DNS disabled opens the login page fine.

Comodo Dragon with Comodo DNS settings disabled DOESN’T open the login page for me BUT it did work BEFORE I changed my ISP DNS settings to Comodo’s DNS settings.

Internet Explorer with the same DNS settings, WILL let me login. Why is that when it’s the same PC and DNS settings? The only difference is the browser. If that’s the case, I might as well not have the browser. Am I right?

This is crazy. None of this happened before I started applying Comodo’s DNS settings.

There is a setting in Comodo Dragon that enbles SecureDNS for Comodo Dragon (it basically bypasses the DNS you have in Windows) make sure this setting is not ticked, I believe the setting says something with malware and might mention SecureDNS but I’m not sure and can’t check since I’m on a mobile device at the moment.

I have just unchecked that box and you’re right. Comodo Dragon has now let me login to that page. I want to say thanks to you for being there with the quick responses today and helping me get things sorted.

As for the bug report though, I’m gonna have to leave that until I’m in a better mood :slight_smile: ha.

I’m glad it’s working now. :slight_smile: