Comodo cuts into my games

I have just started playing games and have found that COMODO is interrupting it quite a few times, usually at the wrong point. How do I know its COMODO? Well at the taskbar there are two icons that appear and as the game is interacting with the internet I can only presume it has something to do with that. I have checked if the game is logged as a safe interaction and it is. So what is happening that it interrupts the game?
I have Win7 64 bit and use the free version Comodo firewall

this is a known annoyance. the second icon you see is comodo checking for updates. the updater takes focus you have to disable automatically check for updates under more → preferences

Thank you I shall do that

Or you can put a check in the “Run in Games mode” option if you right click the Comodo task bar icon. This will stop the AV updating while you are playing games, just remember to uncheck it when you are finished or your AV will not update.

Yes I sure do. I run gamebooster and Processlasoo in game mode as well. Thank you for the help