Comodo Corrupted. Can't Reach Internet

My first post, unfortunately looking for help.
My free install of CIS experienced some corruption.

Upon startup I got a message saying Entry Point Not Found. Text “The procedure entry point CmdResLoadStringByDigitalld count not be located in the dynamic link library c:\Program Files\COMODO\COMODO Internet Security\cistray.exe”

Thought to just uninstall, but that did not work and also resulted in an error message.

Figuring corrupted files, tried to install a new version but that also failed at around the 40% mark, getting the same message as first noted.

At that point, I attempted to use the new COMODO Uninstaller tool. Got rid of the program but I still had the message popping up.

Get’s a little weird here. I accidentally allowed a windows update to take place. Upon reboot, while I still received the noted message, I was able to get to the internet. Unforutunately, attempting to address that message, I lost the internet again.

I am stuck and don’t know how to fix this problem. Comodo CIS is intrentched and I don’t know how to clean it.

Help would be greatly appreciated.

Hi, jbrajuka.

Thank you for reporting. Your issue is under investigation.
Could you please try to uncheck Comodo Firewall Driver in LAN properties, reboot PC and check again, does the issue with Internet connection persist?

Please let you know results and provide screenshots of errors.

Kind Regards,

Hello Sergey

Thanks for your suggestion, that worked. Doing that means I don’t have Comodo running. After a reboot, I still get the CISTray.exe message I shared in my earlier post.

How do I fix my Comodo install? I am guessing it won’t be easy, but I want to avoid having to reload the laptop.

Just to point out another issue, when I want to change my adapter options, I get this message. “The procedure entry point CmdResLoadStringByDigitalld count not be located in the dynamic link library c:\Program Files\COMODO\COMODO Internet Security\cavshell.dll”

You could try running Diagnostics and see if that is able to fix it. Click on the question mark in the main interface and choose: Support → Diagnostics. When Diagnostics fail it will ask to save a log file. Save it, zip it and attach to the forum to help Comodo look into your problem.

If that doesn’t help try a clean install. When you want to you can export your active configuration and import and activate in the clean install. When needed you could use the official Comodo Uninstaller to be had from Official Comodo Uninstaller v2.0.0.3 Released.

Thanks for the suggestion Eric.

What “main interface” are you suggesting, Comodo or something else? If Comodo, I had tried to uninstall previously using the Uninstaller tool you made reference to. So, there is no Comodo but elements of it linger.

I meant the main interface of CIS but since you used the Uninstaller tool it is not possible anymore to run Diagnostics.

Could you try running Autoruns and look up under the Windows tab entries for cavshell.dll? When you find them uncheck them. When using Autoruns first go to Options and choose to hide Microsoft and Windows entries just to be on the safe side of things.

Next step is to unregister the cavshell.dll. For the following I assume CIS was installed in c:\program files\comodo\comodo internet security. If you installed CIS on a different path adapt it accordingly.

Now open a command prompt as administrator and type in the following: regsvr32 /u “c:\program files\comodo\comodo internet security\cavshell.dll”. When successful Windows will tell you.

Sometimes upon uninstalling and re-installing CIS, your Network Adapter Driver might become corrupted. Have you tried to uninstall and then reinstall your Network Adapter Driver? Doing it might restore your internet connection.

Citcat already tried that after Sergey’s advice and that helped.

Hello, jbrajuka.

Could you please clarify, do you have CIS issue(s) currently?

Kind Regards,