Comodo "conflicts" with Logitech Tracball?

I have an odd problem. VERY odd. My Logitech wireless optical tracman is frozen when I boot up after a long off period - several hours, like overnight. (Win XP SP3) (Therefore pretty hard to “test” it.) I have to do Ctrl-Alt-Delete to get Windows Task Manager, then Alt-U, then R, to restart the computer via the keyboard only. After the machine reboots, it is fine! Mouse works great.

This started happening a couple months ago, but then stopped after a month or so. I had corresponded with Logitech and they were clueless. They suggested it was a hardware problem, even though a SECOND same-model tracball did the same thing! Then it suddenly stopped happening - seemingly out of the blue.

But it began happening again recently. On 12/19/11 I updated Comodo Firewall from 5.8 . . . . . to 5.9.219747…
On 12/21/11 the mouse freeze thing happened again, and continues. Another update to Comodo occurred - 5.9.21986 . . . . the current version. The mouse still freezes. Not a killer, but the workaround is a pain in the ■■■■. I don’t think I’m running Logitech software - Control Panel just says PS/2 compatible mouse.

Is this an interaction conflict with the Firewall? I have been using both items for years with no issues.


Can you show a screenshot of the D+ logs (they are under View Defense+ Events}? May be there is a clue there.

OK - Attached is a screen shot of the log - is that what was requested? (Took me awhile to find “attachments” under “Additional Options.”)

Seeing the BOSS RiverCAD stuff - some engineering software, now defunct I think - I have a USB “key” to operate it. I’ll try unplugging that and see what happens.

[attachment deleted by admin]

The problem is intermittent. That makes it hard to track down. Does this happen with every cold boot? Does it also happen when you turn of the computer for a few seconds and turn it back on?

I hoped that D+ alerts would show Logitec software trying to access CIS files in memory (which is a common cause of problems with mouse or touchpad software) or something else. But that is not the case. That makes influence of CIS not an obvious one.

You could try to see if removing CIS or disabling D+ helps to show whether there is an influence or not. To disable D+ you need to use Deactivate Defense+ permanently (Requires a system restart).

A completely different angle would be the electronic angle. May be capacitors in the mouse are getting old and need to be replaced?

Actually - “you” solved my problem, by giving me the key to look where I hadn’t been looking. The problem was only on a cold boot after several hours of “off” time. And I tried two different same-model trackballs.

But the answer is the USB key for the RiverCAD software, apparently. Seeing the log reports made me unplug that as an “experiment,” and I haven’t had a frozen mouse in the last two or three days since. I’ll plug it back in and see if my mouse freezes recur - if so I’ll know for sure that the USB key is it.

I had no idea that it could somehow interact, so I paid no attention whether it was plugged in or not. Combined with the requirement for the computer to be off for a couple hours or more - I just never suspected the USB key until the saw the Comodo logs.

Thanks for pointing me in the right direction! And sorry for suspecting that it was Comodo Firewall.


Congrats with solving it.

The D+ logs sometimes can hold a clue as to what is happening. What I see in the D+ logs is that RiverCAD gets blocked for writing to protected registry keys. Can you see if it may be gets sandboxed?

No need to apologise for suspecting CIS. D+ is intrusive enough to be able to cause such problems.