comodo confilcting with audio drivers

my audio drivers stopped working and every time i reinstall them, they stop again at the next reboot. later on down the road for a not related reason i reset my computer to factory default (i wish they gave you oem disks these days…cheapskates) anyways audio drivers working find…and i get around to installing comodo…next boot they stopped working, so now you see why i believe it to be comodo.

now the easy way out is to uninstall comodo and get another firewall…but i really like comodo, on top of the fact that there arn’t many amd64 firewalls out there, let alone open source ones. so i’d really like to get my firewall and audio drivers to play nice, XD
any ideas, productive thoughts would be much appreciated!

(btw: i know my way around a computer, but just to be on the safe side any comodo specific explanations should be explained like i’m an idiot please, XD)

Welcome to the forum itachis.eyes :slight_smile:

A few questions.

  1. Which audio drivers are you using?
  2. have you enabled Defence+, if so what settings are you using?
  3. Have you checked the D+ logs for any related entries?

First, welcome to the Forum, itachis.eyes.

Second, make sure your sound drivers are the latest from the manufacturer of your sound card, not from the retail site of your system (same applies to onboard sound from mobo mfgs).

Third, what OS are you using. Is there any other security software installed/active?

Fourth, what version are you using (CIS)? Is it the full CIS or just a part of it (e.g. Defense+, not the firewall portion) that is causing a conflict? There are three parts to CIS - the firewall, Defense+ (HIPS), the AV. Each can be disabled independant the rest.
This can be tested by (e.g.) disabling Defense+ to see if your sound issue remains even with the firewall active. Defense+/Advanced/Defense+ Settings.

-i have in fact updated the drivers
-vista home premium amd64 (64bit), i also have “Avast!” at the moment, but i ran the computer through several reboots after installing avast and they worked fine (all before installing comodo)
-i have 3.9 CIS with just the firewall and defense+ activated since installation

one more note, although the speakers don’t work, i can plug in headphones and hear audio, however hardware failure isn’t the culprit, after reinstalling the drivers the speakers resume working…of coarse until the next boot up

Could you supply the information I requested also, please.

You stated the drivers are updated. Was this from the OEM or the manufacturer? The manufacturer usually has more up-to-date drivers than the OEM.
Can you confirm if it is CIS firewall or CIS Defense+ (or the AV) that is conflicting.

the driver is “IDT-Audio-IDT High Definition Audio Codec”
i do have Defense+ activated logs from Defense+ don’t say anything about the drivers
also a couple of days ago i switched from training mode to safe mode

i got them from IDT (the manufacture)
other then it happening right after the install and reboot of comodo i can’t say with 100% certainty, i’d say i’m more of 80% sure

There is no recent driver available for this as the mfg is not making/providing drivers.
(M$ has not been much help here, either)
A Google search shows many many users are experiencing issues similar to yours with their drivers. The issue is your audio driver, not CIS.
I take it you are using a laptop? Unless you can change your audio hardware, the only recourse you have at this point is to disable Defense+. Defense+/Advanced/Defense+ Settings.

yes i am using a laptop (my house would be a hardwire network nightmare if i used towers, XD)
ok, well thanks for your help and time, i really appreciated it (i looked around a few other places for insight and they didn’t even respond lame) so i’ll see what i can do, as far as hardware (as i’m sure you know laptops are like a Pandora’s box of wires and this and that with hidden screws…i have had “good times” with my older laptop, XD) on the other hand i’m glad i get to keep comodo intact (great product, always refer it to friends)

once again thanks (^_^)

This is a tricky one. As John said, there seems to be a great many people having problems with Vista and these drivers. I assume you have SP2…

it’s possible there is a clash between D+ and these drivers, again, as John says, install CIS without D+ as a test, it can always be enabled later.

In this case, the driver requires updating, but there is no recent update available. Disabling D+ is the only recourse at present.

i’ll give it a shot

i’ll try it out