Comodo cmdagent using 100% cpu resources on startup

I thought I had seen this topic somewhere in the forum before but not associated with the latest DB updates or latest av updates. I am completely up to date with all aspects of the comodo software and yet every time I start my computer up Comodo cmdagent uses 100% of my cpu resources. It completely interferes with opening new programs or running even my email program. I don’t know why it is doing this and would like some help to fix the problem. I am using Windows 7 with the most recent version of Comodo. This has been happenng for almost 4 weeks now.

any advice would help

Does cmdagent eventually settle down? If so what percentage does it idle at, roughly?

Thanks for answering me Chiron it does eventually settle down after usually 1/2 an hour or so, which is much longer than it ever was before and it is right now idling at between 41% and 45% but was using more earlier when I had several programs open.

Okay. In that case would you mind reinstalling it by following the advice I give in this post. Be sure to also run the removal programs for any other AV products which have been removed from your computer. Reinstalling by following these steps may be able to solve this problem.

If it does not, please edit your first post so that it is in the format provided here. Also attach all required files. This should be able to give me a better understanding of possible causes. Also, only posts in that format can be forwarded to the devs.

Let me know if you have any questions.


I will follow your instructions and hope it settles down, irregardless I will post back here to let you know what happens after I reinstall it… thanks again Chiron

this has been a nightmare I didn’t need… first of all I used the comodo uninstall tool in safe mode that you recommend in your thread and used it to uninstall what I thought was all of comodo internet security pro here. I then booted up in normal mode Windows 7 and the keyboard wouldn’t function at all. I ended up using the onscreen keyboard in Safe Mode to get back into Windows and then restored the restore point I made when I started this uninstall.

So finally back to my normal windows desktop in standard mode and reinstall the copy of up to date copy of CIS I had downloaded before starting this nightmare and get an error message telling me I have to uninstall the comodo firewall before proceeding. Now do you think I can find this so called firewall… nada anywhere on my hdd… so I assume I now am operating without a firewall of any kind and haven’t a clue if I have a full copy of cis or not aqs there is no comodo icon in the system tray at all… so now what do i do? guess I have to start from scratch uninstalling the entire comodo software again and reinstalling it hoping I don’t have to lose my keyboard again… a super nightmare to say the least…

Do you have any other security or maintenance programs installed? If so uninstall them and (at least for the security ones) then run a removal tool for them.

Also, even if you do not have any other security programs installed, run removal tools for them before attempting to reinstall CIS.

As something appears very wrong with your system at the moment, I would recommend following all steps in my topic. Please let me know if that helps.

Sorry this is becoming such a trouble. Hopefully it will be resolved soon.

thanks Chiron… other than comodo not functioning at all… … my laptop seems to be functioning normally. However I am having a problem with my connection to the internet but that my be because comodo is blockng some ports as it is functioning partially. … I did follow your ports very carefully to make sure I did everything you recommend … when I did the system restore my keyboard came back to normal use without any problem at all. So not sure what is wrong other than comodo not functioning but I have no intention of surfing at all other than to come here…I will attach the report I made of the problems ,anyway here is the report.

[attachment deleted by admin]

forgot to mention I have no other programs installed on my computer even in my zip folder as I uninstalled all of them when I installed comodo pro in February 2013

Chiron I will post again tomorrow after trying another uninstall/reinstall as I have to get to bed now… it is late here on the east coast… thanks again Chiron for your help

Thank you. Please try to follow all steps this time, as there may be something driver related left on your computer.

grrr I have followed each step in your post just as I did the first time but I did not use the cleaner because it had nixed my keyboard last time, now I enter my license key that is supposed to be good for 1 year paid for on February 4, 2013 and I get a message that my license key is expired when it had 186 days to use as CIS PRO yesterday. How do i get it to give me back the time I have already purchased?

when I shutdown and started the computer again it started a full install of comodo premium because I don`t seem to be able to log in to my account at Is this why i have the problem with the license key?

For the moment let’s not worry about the license key. Worse case scenario I’m sure Melih will take care of that.

Besides the license issue are you experiencing any other problems with CIS? Is the CPU problem solved?

when I couldn’t access half of comodo through either killswitch or the task manager I finally got so frustrated that I clicked on geekbuddy and Jonas came up to help me with the license key issue and the other problems I was having.

He used a different uninstaller than the one you have in your post from the comodo website that uninstalled in dos. He then went into my registry and though I hadn’t checked it recently there were a lot of entries for other security programs because I used online scanners if I think there may be a virus or malware problem that comodo isn’t catching. (so far comodo hasn’t missed anything BTW other than a few temp files that weren’t particularly hazardess) He deleted all those entries in my registry before rebooting my computer twice.

Then reinstalled cispro x64 on my system and started a full scan to activate my warranty. After a reboot it didn’t show that a full scan had been done so I have to do another one to activate my warranty tonight. It then did a quick scan without finding any threats.

After all this he was able to remotely activate my license key so it showed the total number of days I have left before expiry. I was still unable to activate my license key after the reinstall so hopefully I won’t have to reinstall it again. Not sure why it didn’t register that a full scan had been done, but I leave that up to the software engineers to figure out.

Just thought you’d like to know I had hoped to copy the URL of the uninstaller he used for you but I don’t find it in any of my log files.

thanks again Chiron for your help, it has given me the process to go through if anything happens again with high CPU usage.

Okay, as everything seems okay or the time being, I will move this bug report to Resolved. If you experience any further problems, including the CPU issue, please let me know and we’ll see what we can do.


Thanks so much for all of your help Chiron it is very good to know there is a good forum attached to Comodo that has people like you as members to help people through any problems they may have.

I had trouble getting the warranty activated and ran 3 full scans of my hdd before I was able to activate it. Other people may find this problem after reinstalling CISPRO X64 that’s why I mention it. The first two times I ran the scans overnight and clicked the box to shut down if no threats were found. When I woke up each morning and checked under FULL SCAN it still said NEVER for the time it was done. However a full scan was listed in the log files. So on the third day I ran the scan in the background while i was using the computer and was able to activate the warranty when the FULL SCAN finally finished. So all is well now and Cmdagent is no longer using 100% resources.

Thanks again Chiron