Comodo CIS V3.10.102363.531 No antivirus

Could someone explain what to do here, please?

I did a clean install of the latest version of CIS and have had no problems on my desktop computer. However I updated CIS on a different computer and although the “About” gives the same Product Version as my clean install on the other computer, there is no Antivirus. Can someone tell me how to activate the antivirus part of CIS .

When I open CIS on my desktop computer The display has “Summary” “Antivirus” “Firewall” “Defense+” and “Miscellaneous”. On the other computer the “Antivirus” is missing from the display.

Does this mean that I will have to uninstall it and do a clean install or is there a way to install the antivirus without doing that?

I forgot to remove my current antivirus program, might that be the reason for there not being one in CIS

there is a uninstall or upgrade entry in your comodo internet security folder on you start menu. If you run this and select add/remove then check the antivirus check box at the top. It should install the antivirus module.

Please make sure the other options are ticked do not just tick the antivirus option only otherwise the firewall and Defense+ will be uninstalled when you install the antivirus.


[attachment deleted by admin]

lol yea good point.


Thank you both for your help and sorry for the delay in replying - I have been trying to set up a wireless network that doesn’t want to be set up.

There isn’t an Install/Upgrade facility in my Comodo folder, so it looks as if I will have to uninstall it and do a clean install, unless I can run one of the files in the “Repair” folder, but I am not sure which one it is likely to be.

Nothing like this?

[attachment deleted by admin]

No. No sign of that at all.

Odd have you tried running the uninstaller to see if it gives options like I posted in my first screenshot.

Yes, if you use the Windows add/remove programs and click the Change/Remove button, it should give you the add features option.

You may have to uninstall CIS and do a clean install.

Hi Dennis2,
No I didn’t try running the uninstaller because there wasn’t one. It seems that CIS was only half installed, if that is possible and still have it running (or appearing to run). As I have had trouble uninstalling Comodo software before, when it was simply Comodo Firewall Pro, I uninstalled it using Revo Uninstaller and then cleaned the registry with a registry cleaner and finally looked for any folders that might be to do with Comodo and deleted them. Just for good measure I ran the cleanup file that is available in the forum. Then when all appeared to be OK I downloaded the latest CIS and installed it and all went like clockwork. I now have a fully-functional CIS and all that remains is to remove the other antivirus program that I had been using

Thanks everyone for your suggestions and help