Comodo CIS & ParetoLogic DriverCure

Has anybody downloaded ParetoLogic DriverCure, can you get it to work? I have the Comodo CIS and downloaded ParetoLogic DriverCure as I know my drivers need attention but I can’t get it to run. Every time I click start scan it runs for a fraction of a second then stops and I get a message to verify my internet connection, I can only assume it’s something to do with the firewall? I have tried disabling the CIS, even tried shutting it down completely, same thing happens.

I have contacted ParetoLogic, they reckon it is a security issue but I’ve tried everything they’ve suggested. ParetoLogic is listed everywhere I can find in the CIS as a safe programme, I have removed and reinstalled it but nothing seems to make any difference?

Any suggestions would be greatly appreciated.

Hi dipolog.

You know these types of programs are really unnecessary. I appreciate that using something like this may seem to make finding drivers easier, but it’s not really that hard to do it yourself.

When you think about it, the drivers you may or may not need are likely to be:

  1. Graphics (ATI/nVidia)
  2. Sound
  3. Chipset

There may be others, but these are the main ones.

If you know what your Motherboard is and what your graphics card is, you can find the answers very easily.

Anyway, that aside. if you do want to use we need to look at your firewall rules and probably your D+ policies.

I’ll take a look at this program and see what it needs.

If you decide you can do without this application, please feel free to ask for help finding what you need.

Toggie, thanks for getting back to me I don’t think the problem lies with the Comodo CIS. I took the drastic step of temporarily uninstalling the CIS, rebooting then disabling the Windows firewall so there should have been no barriers what so ever, DriverCure still wouldn’t run, getting the same verify internet connection message.

I’ll have to bounce the problem back to ParetroLogic.

I did download the product, it only required a rule for TCP out port 80. Do you have Windows firewall enabled?

Windows firewall enabled or disabled, CIS running, disabled, even uninstalled doesn’t seem to make a blind bit of difference! Something is blocking DriverCure and nothing else, no problems with any other application, only this one.