Comodo CIS and Steam Problem?.

I have just installed Steam in order to play the latest version of the football management game FM2013. The install went fine but when I get to the create new account screen I enter my details but the get the message that Steam cannot get online although my broadband internet connection is working fine. It is the first time I have tried gaming through the Steam program. Do I need to set some rule for it or is there another reason it won’t work. Appreciate any help offered. My OS is Win 7 and I am running CIS v6 in Proactive mode set up the same as Chiron’s tutorial over at Gizmo’s.

Can you post the exact message you receive from Steam please.

It just says Steam is having trouble connecting to the Steam servers Radaghast.

[attachment deleted by admin]

Look in the logs what has been blocked.
The column logs in version 6 have to be resized unfortunately to see informations.

In general:
Steam needs outgoing rules only, as long as you dont plan to run a server.
More specific, it needs UDP+TCP outgoing.
Like games. And usual programs.

Steam can run fine with comodo. The logs are the key to solve problems.

It works fine for me in the default Internet Security config. In fact, since Steam is white listed, no rules of any kind were created. I read Chiron’s guide but chose to only follow a few parts of it. I checked the firewall options he gave, put the BB to restricted, enabled the AV alerts to prevent the potentially dangerous auto quarantining, and that was it. Steam has updated twice with no problems and Skyrim, RAGE, and everything else works fine.

It actually seems to me that your problem is exactly what it said. The Steam servers were having problems. It happens.

Not a hugely helpful error message :frowning:

Anyway, there shouldn’t be any problems using Chiron’s configuration with Steam, I tried it earlier and it went through ok. Apart from the suggestion from Clockwork, I’d be inclined to narrow down the problem, make sure it is an issue with CIS.To that end, if you don’t find anything in the logs, I’d temporarily disable the firewall and see if it connects.

Thanks for the replies guys, I will try them out and get back to you.

I checked the logs and there is nothing blocked in regard to Steam. I took Clockworks advice and set the rule for Steam to outgoing only. I still couldn’t sign in so as I had used CPM to install Steam I used it to uninstall and deleted everything it found. I then went to the Steam website and signed in using the account I had created and was signed in ok. I then downloaded and installed Steam again. Everything went fine it installed ok and updated itself ok but once the update finished installing I got the same sign in option this time signing in with the same details I had used for the website sign in and again got the same message box as shown in my PNG above.
Two things I should add here are firstly that I haven’t installed the FM2013 game yet as I wanted to ensure Steam was working ok before doing so. Would this have any bearing on this problem.
Secondly in my PC cable broadband setup I am running a Virgin Hub in modem mode through a Buffalo G300Nv2 router flashed with DD-WRT which has been kept updated to the latest DD-WRT version for this router of which the latest DD-WRT v24-sp2-build 20548 was only released yesterday and updated by me today in between uninstalling and reinstalling Steam. I haven’t had any problems running any other of my programs with my router but have read on the steam site that apparently it does suffer with some types of router although mine didn’t appear on the list shown could the router be a factor?.

I’d be surprised if the router were the problem but anything is possible. As I suggested earlier, you need to start eliminating potential areas of conflict. Start by placing the PC with Steam, in to the router DMZ and see if it connects. Whist in the router check the logs. If it connects, try disabling the CIS firewall and see if it connects.

Excuse my ignorance Radaghast but i’m not sure what you mean. I just looked in the Router settings and it says that DMZ is disabled.

This may help. It’s from the settings in my router.

The DMZ feature allows you to specify one computer on your network to be placed outside of the NAT firewall. This may be necessary if the NAT feature is causing problems with an application such as a game or video conferencing application.

It also says to only use it temporarily since the computer in the DMZ is no longer protected from hackers.

I first tried switching Comodo off and still could not sign into Steam. I next went into the router settings and allowed the DMZ and tried to sign in to Steam but got the same message again. I have now changed the DMZ back to the default “Disabled” setting. Could it possibly be that I need to use port forwarding though I am not sure what that is or how I should implement it?.

If you have the possibility you could try skipping going through the router and plug your PC directly into the modem, if you still have issues logging in then it’s not the router.

Could it possibly be that I need to use port forwarding though I am not sure what that is or how I should implement it?.
That could be possible and is why my router is allowed to use UPnP which automatically allows ports for those applications requesting and requiring them.

Placing a device in the DMZ will bypass the router settings, so if it’s an issue with ports, you’ll be able to tell. Doing this is not something you want to make permanent, it’s simply a test to determine where the problem may lie. With dd-wrt, just enable the DMZ and add the IP address of the PC.

As far a s port forwarding is concerned, you shouldn’t need to configure anything for outbound connections, but if you were hosting a game server, it would be a different story. However, if for some reason, dd-wrt does need ‘opening’ you can use the information found here In dd-wrt, if I remember, you can use the ‘NAT/QoS/Port Forwarding - Port Range Forwarding’ console to set your ports. This is the same tab to enable UPnP, which is worth a try providing you haven’t disabled UPnP/SSDP in Windows. Personally, I wouldn’t use UPnP, it has number of potential security issues, although with dd-wrt, you’re probably ok and it can make things easier.

If your router would need port forwarding for playing games or using steam,
you allready could not browse with your browser in the internet.

You can read a lot of things in the internet. And sometimes people call something a solution, just because it works. They forget the price.
Some even disable their firewall for gaming. “Because that works”. :smiley:

Is it the first time that you try to log in to steam? Or what has been the last thing happening before the problem started?

From what I can gather from your replies it can’t be the router as I have never had a problem before with internet access. From my router I am running this PC Win7, another PC win XP, a cable to the ethernet connection on my 3D BluRay player which gives me access to some internet functions on my TV and another extension which I use when my son and/or my daughter are visiting and want to use their laptops. All of this works without me having to do anything other than plug them in and start my Virgin box - Router - PC in this the correct sequence. I have read over at the SI forums (FM users) that lots of people have had problems connecting to Steam at first. I think my best bet is to leave it until I install the game once it arrives and then try again when I actually have something I want Steam to connect to.

If you haven’t already, you could add logging to any firewall rules you may have for the Steam client, it may show where the response, if any is originating. (did you check the router logs?) Failing that, you could use something like wireshark to investigate.

Sorry but you’re absolutely wrong. Many games require that ports be forwarded through router firewalls. World of Warcraft is one example and things like uTorrent also require it. The easiest way to take care of it is to enable UPnP in the router. Otherwise you will have to forward the ports yourself in the router settings.

Not all routers.