Comodo changes my IP address upon installing

When I install Comodo Firewall (the regular release version or the beta) I no longer have a network connection. If I uninstall, the connection comes back. I’ve searched the forum but haven’t found the answer. I tried adding a trusted zone, I tried manually setting the IP address to what it should be (changing the setting from "Obtain IP address automatically), etc. Even when I set Comodo to Allow All, or even turn the program off, I still get no connection. The only way I’ve found to get the connection back is to uninstall. On my other machine it installed and works fine.

Anyone have any ideas?

I’m running Windows XP Pro with all service packs and updates. I’m connected to a hub that’s connected to a router. This is a home system, not a college or office. And again, my other system, which is identical and on the same network/hub/router, has no problem.


I’m suspecting you’re getting a address. This is something the OS will provide your NIC to prevent it from shutting down the IP stack. The OS will give you a similar address if you don’t receive any answers to your DHCP requests.
All DHCP packets travel as UDP datagrams; all client-sent packets have source port 68 and destination port 67; all server-sent packets have source port 67 and destination port 68. Go over the logs and see if you get blocked or dropped UDP packets on these ports.

Hope this helps.

Thanks for the info. But I’m still not sure what to do about it. For example, let’s say there IS a problem with those ports, what do I do? Also, do you mean check the Comodo log or the Windows event viewer? Sorry about being so dense-- this is just one area of computers I just don’t know very well. Ask me about 3D animation software and I’m quite a bit more knowledgeable. :slight_smile: (Here’s a link to the current project a friend and I are doing:


Hey Fred,

If you ever think you have a problem with a rule or with ports being blocked, the first place to look is the logs. These are found in ACTIVITY - LOGS. Click on an entry and details of the log entry are shown at the bottom of the window. If this doesn’t give you enough of a pointer to the cause of the problem, you can do a right click on the logs and export them. That way the logs can be sent to the forums for someone to check out.

To find out what IP address is actually assigned to the card, start CPF (I realise this is what you’re complaining about, but this is where we have to start - ;)) and once you’ve determined that the IP has changed, click START and then RUN. In the RUN window, type CMD to open a DOS-style window. In the DOS box, type in IPCONFIG /ALL. This will display the current settings of the network adaptors in your PC.

Find your network card and it should show the IP address currently assigned to the adaptor and write down the assigned IP address that is in use when things are pear shaped.

Now, stop CPF and once your network settings are working again, repeat the above steps and write down the IP address assigned to the network adaptor when things are working.

When you’ve got these two addresses, post them here, along with the IP address of your router and the IP address of the PC that works when CPF is on.

Ewen :slight_smile:

P.S. Really nice graphic style on the anim, BTW.

The same happened to me, I solved going to /start /run /cmd when you’re in cmd (it will look like DOS) you have to write netsh winsock and press enter and then write reset and press enter again, after that you restart the computer and you have internet :slight_smile:

OK, I’ve tried everything and checked everything mentioned here and still no go. There’s nothing even in the Comodo log, so there’s nothing to investigate there.

When things work the IP address is:

When things don’t work the IP address is:

On the computer that works fine with Comodo the IP address is:

I don’t think this has anything to do with my settings in Comodo, which are default, though I’ve tried adding a trusted zone too, which didn’t help. The network connection doesn’t work even when Comodo is turned off. I don’t mean set to “Allow All,” I mean actually shut down. There’s something that Comodo changes during installation that’s causing the trouble.


You are saying that there are no entries in the log or that there is nothing being shown as being blocked in the log? Are you getting any listings in the log at all?

Something to check:
In Network Monitor check the very bottom rule that is the default block rule and make sure the checkbox is checked that says “Create an alert if this rule is fired”. I would do this to all of the rules in Network Monitor so that all activity can be seen from the log.


Jasper, I’m saying there are no entries in the log at all. Also I did look at the bottom rule. I even set it to allow. Still no luck.


Is the checkbox checked on each rule? You didn’t say in your reply.


Sorry, yes they’re checked. Still, if there’s a problem in there wouldn’t it cease to be a problem if Comodo is turned off?


Well it should but this one seems to be a stinker.

Ok, the things we do know is that it works fine without the firewall. And it doesn’t work when the firewall is installed. If it is getting a 169.x.x.x address then possibly it’s not seeing the correct NIC card.

When you have the firewall installed are the Trusted Network rules that CPF automatically creates seeing the correct NIC card. Check both rules that CPF created at the top of the rules list to make sure it is seeing the correct NIC. Do you have any other kind of card installed that might be seen as a NIC card(TV Tuner comes to mind)?

Do you have any USB external drives or dongles plugged in? Do you have any other firewalls installed or just disabled?


It’s seeing the correct card. I’ve tried everything here and everything in the similarly titled other thread and nothing seems to help. Again, it’s got to be something that happens during setup, because I have the connection problem even when the firewall isn’t running.

Other things I tried:

  1. Creating a new connection while CPF was installed.
  2. Creating a bridge between the Ethernet and 1394.
  3. Repair
  4. Manually setting the IP address back to what it’s supposed to be.

Nothing works, whether CPF is running or not. The only way to get the connection back is to uninstall CPF.

I have no other firewall installed or running (well, the XP firewall is installed of course, but not running). No USB external drives, but I do have a USB dongle.

Up until about two months ago this system had Sygate running (the one that was part of System Suite) with no problem. Then for a month I had the trial of the AVG firewall, again with no problem.


PS: An interesting twist… I figured I’d try installing Sunbelt Kerio firewall just to see if that had the same problem too. But upon installing it it told me it couldn’t because “A higher version of Sunbelt Kerio Personal Firewall is already installed.” But I’ve never installed it. And I checked my Program Files and registry and couldn’t find anything. I guess there’s still some kind of remnant of a firewall on the system but I can’t find it.

I have seen dongles kill network connections and that is why I’m asking. The dongles I’ve worked with were mainly used for allowing top secret high-end 3-D graphics programs to run with very tight restrictions and sometimes they would mess up the USB root in Device Manager which somehow would mess up the network connection. I know how we fixed them but I don’t want to be responsible for messing up your machine since it does work without CPF installed.

My last suggestion for something to try would be to take out the dongle and then try to reinstall CPF with the dongle unplugged. My thinking is that something hardware-wise is killing the connection before it even gets a chance to try and connect.

If that doesn’t work then maybe one of the other guys or gals see something I am missing. (:AGY)


Hi, fwtep

And I checked my Program Files and registry and couldn't find anything. I guess there's still some kind of remnant of a firewall on the system but I can't find it.
Try:- My Computer>Properties>Hardware>Device Manager>View [left click]>Show hidden devices.

That is where you find [if any] your left over drivers, be Very Careful in what [right click] you uninstall.

Also so check that your WinSock is not corrupted or broken, WinSock XP Fix.

Take Care,
TheQuest 8)

I was just thinking and possibly it thinks that your dongle is a PDA (they have the 169.x.x.x address also) but there is no operating system to interact with Windows on the dongle. It just came to me after I went outside to clear my head and lick my wounds and smoke about 10 cigarettes. ;D

If that turns out to be it then I wonder if you made your Trusted Network rule from 169.x.x.x(put in the exact numbers) to the last network address on your lan or make another Trusted Network with the 169.x.x.x address for the IP. This might fix it. Worth a shot.


OK, nothing in Device Drivers that seems to be the culprit. And doubtful that it’s the dongle, since the same kind of dongle with the same driver is on the system that works with CPF. Besides, even with making a trusted zone, it still doesn’t work.

As far as the error with Keria, which I thought might point to the problem with CPF, well it doesn’t. The error I got with Keria is a known bug and they have a workaround (installing an older version, then upgrading from that). In addition, I get the same problem with Keria. I should point out again that I didn’t have this problem with Sygate or AVG. As to why I don’t just use one of those, well, Sygate isn’t made any more, and even if it were, I’d like to ultimately use CPF AND CAV.

There’s got to be something that CPF and Keria are doing upon install that those other two aren’t doing.

Anyway, Merry Christmas!


Hey Fred,

Does the problem exist if you manually assign a static address to the network card?

  1. Try setting the IP address manually while CPF is turned OFF.
  2. Check that you have internet connectivity.
  3. Reboot the PC, still with CPF turned off.
  4. Check that you have connectivity.
  5. Turn CPF on.
  6. Check if you have connectivity.

I realise this is the long slow way around things, but sometimes a methodical approach is the only way to definitively work out what the root problem is.

If it fails at step 6 and not before, then it’s something to do with how CPF is interacting with the network card. In this case, make sure you have the latest drivers and retest (a long shot I know, but I think we’re getting in that neck of the woods).

P.S. When you manually assign the address, dont forget to set up the netwmask (, the default gateway and the DNS addresses as well.

Hope this helps,
Ewen :slight_smile:

Hi Ewen,
Tried that already a few days ago. The problem is that for some reason when I set the address manually I don’t get a connection either (this is without Comodo installed). Not sure why, of course. The way I set it up was to just copy what the settings were when it was on Automatic.

I also tried cleaning up the registry, figuring there may have been some stray thing in there that was causing trouble. But it didn’t help. Frankly I’m at a complete loss as to what to try next.


Hi, fwtep

Frankly I'm at a complete loss as to what to try next.
Did you try to fix your [i]WinSock[/i], if not here is the Link to the download again [url=]WinSock XP [/url].

Take Care,
TheQuest 8)

Yes, I tried WinsockXPFix. :frowning: