Comodo bug - a truecript-partition [Issue Report]

The bug/issue

  1. What you did: I’m using TrueCrypt file container for portable firefox and some other software that uses internet connection. I mount that file container to drive letter N. I use comodo firewall in custom policy mode.

  2. What actually happened or you actually saw: Every time I connected this truecript drive and start portable firefox, Comodo pops up and asks me if i wish to allow Firefox to connect to internet. I press OK with “Remember the answers” checked. But if I restarted the computer, comodo doesn’t remember and asks again me with pop up when starts portable firefox.

  3. What you expected to happen or see: I use specials rules to portable firefox. The problem is that every time he ask again (let the connection go or block), and it will the first rule - and this overwrites my old, special rules :frowning:

  4. How you tried to fix it & what happened: I can fix it if I change comodo firewall to safe mode, start portable firefox (which is located in truecript file container, mounted driver, letter N), and when the browser loaded change to custom policy mode: now comodo won’t ask me again in pop up, and my custom rules what I’ve added to firefox won’t be overwritten. Or if I put portable firefox to C drive, there won’t be problem.

  5. If its an application compatibility problem have you tried the application fixes here?:

  6. Details & exact version of any application (execpt CIS) involved with download link: Truecript 7.0a, firefox portabla 5.0.1

  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Get truecript, create an encripted file container, put there a portable firefox. Change comodo firewall to custom policy mode and start firefox. There will be a comodo pop-up: check remember box and allow. Now restart the computer, do the same: comodo will ask it again, he won’t remember :frowning:

  8. Any other information (eg your guess regarding the cause, with reasons): The main problem that I use custom rules, custom policy, and every starts it will be overwritten, because I must click something in the pop-up, and that will be the first rule, not the last…

Files appended. (Please zip unless screenshots). NOT NEEDED

Your set-up

  1. CIS version, AV database version & configuration used: 5.5.195786.1383
  2. a) Have you updated (without uninstall) from CIS 3 or 4: no
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS: no
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
  5. Defense+, Sandbox, Firewall & AV security levels: D+=safe mode , Sandbox=enabled , Firewall =custom policy , AV =?
  6. OS version, service pack, number of bits, UAC setting, & account type: windows 7 ultimate, service pack 1, 32 bit
  7. Other security and utility software installed: nod32 antivirus
  8. Virtual machine used (Please do NOT use Virtual box): nothing.

In an other forum somebody has the same problem: "I’m using TrueCrypt file container for portable firefox and some other software that uses internet connection. Alsom i use Comodo Internet Security.

Every time I start, e.g. Firefox, Comodo pops up and asks me if i wish to allow Firefox to connect to internet. I oress OK with “Remeber the answers” checked. But Comodo won’t remember my answer and will ask next time when I start Firefox.

I guess it’s because every time I mount the TrueCrypt volume, firefix.exe has different hash? Maybe i’m wrong, however, does anyone know how to solve this?


We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


or comodo recognizes these partitions as an external drive, which has a great benefit against same named files on different drives, while one file was in fact malicious.

okay, I have done it, hope now it good. When will I get answer? :slight_smile:

Thank you for your Issue report.

Moved to verified.

Thank you