Comodo blocks Wireless connections [RESOLVED]

Hello All,

I’m Using the integraded WiFi on my Asus motherboard (P5W DH). Comodo block all wireless traffic,
I can find the wireless network with my cell phone and Nintendo Wii, but can’t connect to the net. The wireless network works fine when I turn Comodo off.

Heres a screenshot of the firewall events, while trying to connect with my cell phone.

[Topic Closed: If issue returns PM an online mod to open]

[attachment deleted by admin]

I got it working(sorta) by adding a rule in the network security policy.

I added a rule:

SVChost.exe to allow TCP or UPD In / Out from The MAC address of my Nintendo Wii.
Then I moved the rule on the top of the list.

Now, I’m pretty sure this is not a “safe” rule… :THNK

Can someone please help me out with the rules, so I could set them up safely.

Better yet, If I can get rules where any wireless device can be use in the network, then I wouldn’t have to set up the MAC address when someone wants to use their cell or any other device

You may try to change slightly the rule for SVChost.exe:

Action - Allow
Protocol - UDP
Direction - Out

Source Address - Any
Destination Adress - Single IP - 192.168.0.1
Source Port - Any
Destination Port - 53

With this change it will be safe.

Hey thanks. It didn’t connect with these rules,
but if I change the direction to “In”,it works fine.

Theres already a predefined rule for SVChost.exe outbound connections.

Is it safe this way?

So that rule in my example works fine if you change Direction to In or you use rule with settings any/any/any/any?

Do you have entry in Global Rules Block/IP/In/any/any/any?

Your example works if I change direction to “In”.

The last rule in Global rules is:

Block and Log ICMP In From Ip Any Where ICMP Message Is ECHO REQUEST

Everything else starts with “allow”

Please make one more modification to the rule in my example:
instead of Destination Adress-Single IP-192.168.0.1 use Destination Adress-Any.

It will be more convinient without loss in safety.

Now the ruleset for svchost.exe on your computer is safe.

Moreover, if you want even more safety make another little modification to the rule in my example (and check if it works for you - if not, return to previous value):
instead of Source port->any try Source port->Port range->50000-65535.

It is better to move Block and Log ICMP In From Ip Any Where ICMP Message Is ECHO REQUEST to the top of the list.

Sorry, have missed. Predefined policy “Outgoing only” is safe.

Thanks for your help. Works great now.

The port range didn’t work but no matter.

No problem :slight_smile:

Though, it is better to change Source Address from Any to Network Zone (must be created beforehand with these IP addresses: 192.168.0.59, 192.168.0.203, 192.168.0.217)