Comodo blocks syncing PC time across LAN?

I run a program called NetTime on all of my PC’s. Most of those PC’s run CIS10 and sync with a Master PC that was running Norton360. None of the PC’s had issues syncing their clocks with the Master until I switched it from Norton to CIS. I tried creating several different rules and even disabled the firewall, but no matter what I did, none of the other PC’s could sync their clocks again. I could see and allow the initial request, but the sync would never actually happen, and NetTime would just display an error message. I ended up going back to Norton until I can figure out how to get CIS to work properly. Does anyone have any suggestions?

If you’re running Windows 10 on the master PC make sure the windows firewall is disabled as CIS does not turn off the built-in firewall during installation. Check comodo firewall logs and enable logging of any block rules that you have in global rules section.

Thanks. I did forget to mention that all PC’s are running W8.1. I didn’t think about the Windows firewall until after I had already reinstalled NIS, so I’ll try CIS again tonight.

You were spot on about the Windows firewall. CIS10 has been reinstalled and NetTime is working perfectly. Thanks again for the tip.