comodo blocks my vdsl broadband connection to internet

Hello. Comodo firewall blocks my internet connection on win7 x64 which is a clean install, when the options are set to automatically obtain ip and dns via dhcp. when the static ip and my assigned gateway and subnet are manualy inserted all is fine. i also have avast 5 free antivirus installed, stopping it doesnt work. Comodo firewall is set according to the guide here in the Guides section.windows is updated. at first installation all works great, but after second reboot there is an unidentified network error. windows firewall is off.

here is the firewall events info:


http://www.shrani.si/t/g/zA/o9aMs4M/comodo.jpg

Thanks for your help.

PS. Seems like its a problem with ICS service in win7 x64, it namely cannot be started. i configure it to start auto but it doesnt. when i start it manualy it says that the service started and then stopped. is this my problem? does dhcp need the ics service to run?

Here are more details:


http://www.shrani.si/t/2Q/DO/1axf9wfh/comodo2.jpg

are there any comodo moderators here that are willing to help or do i need to elaborate my problem ?

PS. When i set firewall security level to disabled, dhcp imidiately starts to work, it gets all the necessary data and connects properly, so its definetly comodo firewall configuration that is blocking. and its configured according to Kyle’s Guide in the Guides section.

OK, dhcp still doesnt work, despite off addding my vdsl modem adress to my network zone and configuring it as a trusted network in the port stealth wizzard. sadly i must say i consider changing my firewall software to PCTools or Agnitum Outpost if i cant solve this problem.

The solution above doesnt work, but i’ve found the culprit. its the “do packet checksum verification” option in the firewall attack detection settings section. i’ve disabled it and all works perfect now. seem like comodo is treating some ip packets from my smartcom vdsl modem as none integral or potentially dangerous. but in win xp sp3 32 bit i dont have such problems. looks like the x32 version of comodo is different from the x64 in that aspect.

Congratulations with finding the solution. :-TU

Enabling all the extra attack detection parameters as described in Kyle’s guide sometimes let people run into troubles as you have experienced.