Comodo blocking virtual router

I’m trying to use this application Virtual Router Manager so I have better signal for my phone. When I turn comodo firewall off it works fine but when I turn it on it blocks it and I don’t have internet even though I’m connected. So how do you allow internet connection sharing in comodo?

I have the same problem, and it seems these too:
https://forums.comodo.com/firewall-help-cis/comodo-blocking-virtual-router-how-to-allow-ics-t107724.0.html;msg782384#msg782384
https://forums.comodo.com/firewall-help-cis/problem-with-internet-sharing-through-virtual-wifi-t105907.0.html;msg768468#msg768468
https://forums.comodo.com/firewall-help-cis/cannot-use-hotspot-wireless-while-firewall-is-on-t106009.0.html;msg769169#msg769169
Is there still no solution?

My setup in particular is a PC with internet over LAN on which I run Windows 7 with Virtual Router in order to connect my notebook running Debian wheezy over my PC to the internet.
The funny thing is: ping 8.8.8.8 or even ping google.de or nslookup google.de are all working. I even can ssh into PCs over the internet or to my own PC/Router!
The only thing which is not working is e.g. lynx google.de or browsing in general. Lynx hangs at “Making HTTP connection to google.de”. As soon as I disable Comodo Firewall running on my PC/Router lynx still hanging on my notebook suddenly works and displays google.de.

I really don’t know why anything gets blocked, I can’t find any blocking message in the Comodo-log and I even deleted all global blocking rules and allowed VirtualRouter completely. It’s still not working.

When trying to ftp into an external server Comodo asks me about blocking windows/system32/alg.exe. I allow it and then even ftp works. Only http seems to not work.

I also have Windows 7 on another partition of my notebook. When booting into that and then connecting automatically to the WLAN-Network which Virtual Router provides everything works.

wget also doesn’t work:


wget google.de
Resolving google.de (google.de)... 173.194.32.207, ...
Connecting to google.de (google.de)|173.194.32.207|:80...failed Connection timed out

Connecting to ftp instead works, but really establishing a connection again doesn’t:


wget ftp://ftp.debian.org/debian/README.html
--2015-02-13 04:29:19--  ftp://ftp.debian.org/debian/README.html
           => `README.html'
Resolving ftp.debian.org (ftp.debian.org)... 130.89.148.12,
2001:610:1908:b000::148:12
Connecting to ftp.debian.org (ftp.debian.org)|130.89.148.12|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /debian ... done.
==> SIZE README.html ... 2882
==> PASV ... couldn't connect to 130.89.148.12 port 29625: Connection timed
out
Retrying.

Both wget commands above work if issued directly on my PC/Router.

Edit: Forget those remarks of the Windows partition not having that problem. It also appears from time to time, though it seems that some bytes get through given enough time.