Comodo blocking video stream. Help?!

Hello

I have a network device streaming video to my PC, however, with comodo switched on, the video stream does not work.

I’ve added the port number to ‘My Port Sets’ and IP to ‘My Network Zone’, however stream still doesn’t work.

Where am I going wrong please?

There are two ways to go.

First way is to make your local network a trusted network:

You will need to define your local network as a trusted network by using the Stealth Ports Wizard.

First we need to do some groundwork by defining your local network. That is done under Firewall → Common Tasks → My Network Zones.

Usually you will find it defined by the automatic detection of new private networks. You will see a network defined with an IP address/mask like 192.168.1.x/255.255.255.0. Select and Edit it and give it a proper name like My Home Network.

In case it is not there we will define it. Choose Add → A New Network Zone → enter the name: My Home Network → Apply.
Now select My Home Network → Add → A New Address → choose An IP Address Mask → fill in your local IP address in the first part (192.168.1.x; with x being a number) and 255.255.255.0 in the second part.

Now open the Stealth Ports Wizard → select “Define a new trusted network - stealth my ports for everyone else” → Next → select “I would like to like to trust from a network zone previously defined” → from the drop down menu below choose My Home Network → Finish.

Now we are done. You can see the newly added rules under Firewall → Advanced → Network Security Policy → Global Rules.

Second way is to open one specific port for incoming traffic:

To open the port TCP 1723 for example

First step is to determine the MAC or Physical address of you network connector. Go to Start → Run → cmd → enter → a black box will show up and enter the following → ipconfig /all (notice the space before /all) → enter → now look up the Physical address and write it down.

Notice that Physical address = MAC address

Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port

Source address: Any
Destination Address: Choose MAC address and fill in the found MAC/Physical address
Source Port: Any
Destination Port: 1723

Then push Apply → Now make sure that the new rule is somewhere above the basic block rule(s) as the bottom (the block rules have red icons); you can drag and drop the rules → Ok.

One other common issue for this is the advanced firewall settings.
Please verify if unticking “block fragmented IP datagrams” under Firewall, Advanced, Behavior Settings, Advanced. Solves the issue.