COMODO Blocking Trusted Files

I was playing League of Legends when something happened and it crashed, I have no idea why. I tried relaunching it, and it hasn’t even gotten to the patcher ever since. I think it might be a firewall problem, because every time I try to launch it, COMODO logs the process as a blocked intrusion. I have added it as a safe file in every way I can think it, and it keeps blocking it. I could really use some help. I apologize in advance, I’m not very tech-learned, but if you need any details, please ask and I will try to provide.

(I’m not entirely sure it’s a firewall problem, because I shut it down and it still didn’t work, but having COMODO thing it’s an intrusion is an annoyance at best and is actually contributing to the problem at worst, so I’d still like to fix it.)

Which version of CIS do you have?
Also, did you every get a sandbox alert for these files?

5.5.195786.1383 is the version I have, I don’t have pro.

I’m assuming you mean “ever” get a sandbox notification, and as far as I know no. If you could tell me how to check though, I could definitely know. Sorry, like I said, I’m pretty computer stupid.

EDIT: I think what you mean is the number under intrusions, where it says “# application(s) currently running in sandbox”? If so, it says 0.

This is a very old version. If you wish you can uninstall this and install version 6.0, which is the newest version.

Can you post a screenshot of which files are listed as unknown. Sorry, I forget the exact terminology used in version 5.5.

I’m uploading a couple screenshots, the one labeled 1 is the screen I get when I click on the “intrusions” bit, the one labeled 2 is just the main screen. I’m not entirely sure what you were asking for, since I’m stupid and you don’t know the terms. I’ll have to check out version 6, thanks. But the problem is that I didn’t build this computer, and the person who did set up the firewall, so I don’t know how they set it up and what it blocks and trusts, and I’d have to try to do it all manually.

EDIT: The game i was trying to play is working now; no idea what fixed it, but it’s fixed. This means that the COMODO problem isn’t a huge deal anymore; I’d still like to try to get it fixed, if possible though.

[attachment deleted by admin]

Glad to hear it’s working. Be sure to ask again if something goes wrong again.