Comodo blocking TouchPad

I have installed CIS 3.12 (x64), rebooted as requested and after that…
Windows loaded, I received a “New network discovered” pop-up from CIS, choose allow and after that I received a Defence+ alert that SynTPStart.exe is trying to launch something.

SynTPStart.exe stands for my Synaptics TouchPad program for my laptop.
In that moment my touchpad stopped working and I couldn’t do anything. Keyboard was working but i was not able to make a decision for that CIS alert.

After 1 minute, SynTPStart.exe crashed and I restarted my laptop.
So, Comodo blocked it and I consider this to be a bug. If my TouchPad mouse tries to launch and Comodo alerts, how can I use my mouse if CIS is blocking that app till I make a decision ?!?

Can you please do something about this?

Not a bug but this can be solved. The catch is that the Synaptics program gets halted because of the alert and as a consequence you can’t use your touchpad.

Temporarily slot in a standard USB mouse and open CIS. First step is to add Synaptics to the list of Trusted Software Vendors; this assumes the files of Synaptics are digitally singed. Go to Defense + → Common Tasks → My Trusted Software Vendors → Add → choose Read from a running process → select the Synaptics program. Now see if it gets added or not. When it gets added you can allow the alert and CIS will learn the rules its self.

When that doesn’t work make all .exe and .bat files that are in the installation folder of the Synaptics software. To do so go to Defense + → Common Tasks → My Own Safe Files → add → Browse files → now navigate to the Synaptics installation folders and add the .exe and .bat files. When done Ok and Apply back. Then allow the alert. CIS will now learn the rules.

When you have no USB mouse present boot your computer in Safe Mode and start the Comodo program and do as described in the above.

Yes, these could be posible solutions. I restarted my PC and immediately switched to Clean PC mode and that solved also.

Anyway, an unexperienced user would blame Comodo and possibly uninstall it.
You could also add that file or everything by Synaptics to Trusted Vendors by default. :wink:


P.S.: This is NOT a Firewall issue. It is all about Defence+. I don’t know why was this post moved here ???

I would definitely advice Comodo to put Synaptics in the Trusted Software Vendors list. I had that idea as well.

Moving it to the Firewall help board was not a bright move here. :wink: I will move it to the D+ help board.

Thanks Eric.