Comodo blocking Stagevu from downloading video?

Hello experts. I used to be able to watch videos on stagevu but ever since i got comodo i am not able to anymore. Is there anyway to stop it from blocking divx? Comodo is a great firewall and it would be silly to remove it just for this reason.

If you haven’t already, you’ll need to create a Application firewall rule for DivX Download Manager Service (DDMService.exe) which can be found in:

C:\Program Files\Common Files\DivX Shared\DesktopService

The rule should allow the process to connect outbound over TCP to port 80, at the least:

Application Name - C:\Program Files\Common Files\DivX Shared\DesktopService\DDMService.exe
Action - Allow
Protocol - TCP
Direction - Out
Source Address - ANY
Destination Address - ANY
Source Port - ANY
Destination Port - 80 (you may need additional ports depending on the web service)

If you’re using firefox, you should also make sure that plugin-container.exe, which can be found in the Mozilla program folder, can connect out over TCP to at least port 80. Other ports will be necessary when using different media, such as flash.

[attachment deleted by admin]

For some reason divx isnt located there…?
I really don’t know why. I swear i installed it.

use windows search to find the exe, or perhaps reinstall DivX, unless you’re using a third-party codec?

I’ve found it at:
C:\Program Files [x86]\DivX\

My mistake, i found it at Program Files (x86) > Common Files > DivX Shared > Desktop service
DDMService.exe wont open. I tried opening as administrator as well.

DDMService.exe is not a ‘runable’ file in that it won’t do anything when you double click it. If I remember correctly DDMService.exe is invoked by DivXDownloadManager.dll, which is loaded when you open a DivX media file in your browser. To allow these media files to play, simply create the firewall rules mentioned above.

Okay, im sorry if i seem horribly inexperienced with this lol. How do I create the application firewall rule?

If you’re running the firewall with default settings, you shouldn’t need to do anything, as it’s a trusted application. However, if this is not happening, or you want to create a rule manually, take a read through this page, then try the following:

  1. Select the CIS Control Panel from the System tray
  2. Select the Firewall tab
  3. Select Network Security Policy
  4. Select Application Rules
  5. Use the information in my first post and the images below to create a rule. (images 1, 2 and 3)

Alternatively, you can make a more generic rule by using the following parameters: (image 4)

Application Name - C:\Program Files\Common Files\DivX Shared\DesktopService\DDMService.exe
Action - Allow
Protocol - IP
Direction - Out
Source Address - ANY
Destination Address - ANY
IP Details - ANY

[attachment deleted by admin]

Thanks for the in depth instructions. I followed everything the pictures said but firefox still crashes :confused: it didnt do this before Comodo.

Can you post a screenshot of the D+ logs (View Defense + Events)?

Although not crucial, in my first post I mentioned that if you’re using firefox, you should ensure plugin-container.exe is also be able to connect. Did you check this? It’s also possible this executable is being restricted by D+/Sandbox, if used. (Check D+ Unrecognised Files)

Otherwise, can you explain when firefox started to crash, as this was not mentioned earlier. Also, is it just watching the DivX videos that cause fx to crash?

I searched through there and I couldnt find anything that had to do with DivX, which is strange but i can see why. Firefox freezes before it starts loading.

Is there any place where i can find a tutorial to do this?

Firefox started to crash the day i got Comodo. It used to not do this. And yes, its only DivX.

There’s no reason firefox should crash unless it’s conflicting with something. Would you mind listing the addons and plugins you’re using with firefox, as well as the version. Can you also show a screen-shot of your firewall Application rules.

To check D+:

  1. Open CIS
  2. Select Defence+
  3. Check Unrecognised Files
  4. Open Computer Security Policy
  5. Check Always Sandbox and Blocked files

The firefox plugin-container.exe is not essential, it simply allows plugins to run in a separate process.

Adblock Plus
Battlefield Heroes Updater
DivX Plus Wed Player HTML5

I went to check unrecognized files and it was empty.

[attachment deleted by admin]

As I said earlier, because the DivX player is a trusted application, if you’re using the default settings in CIS, you don’t have to do anything, likewise with non-beta versions of firefox. As such, I’m inclined to believe this issue may be unrelated to CIS. However, to be certain:

  1. Which version of firefox are you using?
  2. What are your settings for D+/Sandbox and the firewall?

Looking at your firefox plug-ins, you have several instances of the Java console, (Java is now at version 7) none of which are necessary. Likewise you appear to have two instances of the Battlefield heroes updater. Also, In your firewall rules, you’re allowing a temporary file (GPI2011), Internet access, twice.

I’d suggest, initially, trying to access stagevu using a different browser. The DixX installer should have added the necessary plug-ins for IE, so give that a try. I’d also try createing a new profile for firefox.

I’m sorry it took so long to reply back. Thanks for helping me out, and I guess it now shows that its not Comodo that is doing it as i downgraded to an older version of DivX and it started working.