Comodo blocking PDF files from opening. [RESOLVED]

last weekend I reinstalled Adobe 9 (latest version)due to somehow having lost the flash player. In the bundle I have Adobe 9,, Adobe AIR as well as the flash players one each for Firefox and IE7 added to my Add/Remove programs list.
After the new install I got a lot of popups from Comodo and also had to remove Adobe from my start up list using auto runs.
When I open a PDF document via Firefox when I am online I have no problems but sometimes I save these PDF files in a folder in my Documents. When I went to open one of these tonight I get a popup from Comodo saying:

Security Considerations,
drwtsn32.exe was allowed to be executed previously. However a new parent application, AcroRd32.exe, is detected and it could not be recognised. Once the application is executed, it’s parent will have the full control over it’s execution. If AcroRd32.exe is one of your everyday applications, you can safely allow this request.

I googled the AcroRd32.exe and it is a legit Adobe file needed to open it. I also did a search here but found nothing.

I ok it but then nothing at all happens. at first I just thought it was slow but nothing at all happens. I even went into the Firewall and changed the Network security policy from Custom to trusted application. I still can’t get any of my saved PDF docs to open. I ok the Comodo popup but Comodo seems to just ignore it.

I have the latest verion of Comodo on my PC. The only other thing I can think of was that when I first opened a PDF file after the reinstallation I got a few popups which I okayed but I denied one asking for permission for Adobe to go online. I think it was the updater and as I prefer to update manually and don’t like too many programs on my start up list I denied it access and then unticked the relevant box in my Auto runs scan.

Can anyone explain what I have to do to get Comodo to allow my PDF files to open?.

To add;

I just decided to try to open the PDF file online. I opened Firefox and found the link but as soon as I tried to open the PDF file Firefox crashed. I reopened Firefox and repeated the procedure and it crashed. Just to be sure it was Comodo and not Firefox I entered a non PDf link on the same search page and it opened ok, I tried one more and it also opened ok. I then tried to open a PDF link and Firefox crashed. I hope some one can tell me what is going on and how to resolve this issue.

Try finding any instances of Adobe in D+ and FW, click and remove. Then open adobe in training mode, then open FF (set to browser) and open a pdf link.

Problem solved. I dowloaded a new copy of Adobe etc and uninstalled the old one, I also deleted all Adobe folders in Program files open and hidden. I then restarted my PC and purged Comodo. Then reinstalled Adobe etc and it is working fine now. Thanks for the reply anyway Hikertrash javascript:void(0);

Glad to hear that, I’ll go ahead and mark this as resolved. To open the thread again, send a PM to any online moderator!