Comodo blocking new Ipod Touch !?

I need help please. I’ve got a new Ipod Touch and I’ve tried everything to allow all of the Itune applications. I’m pretty sure Comodo is blocking it - when I plug in the new Ipod in, it is not installing or showing up at all.
I’m at a point where I"m ready to uninstall Comodo just so I can get my new Ipod registered!!
Appreciate any advice!!

When you say it is not installing or show up. Does the iPod show up in Explorer or Device Manager? I assume it doesn’t show up in iTunes. Is that correct?

It does show up in Device Manager, however does not show up in Itunes or Explorer.

Try removing the rule for iTunes and let CIS make new rule. Does that make the iTouch visible in iTunes?

When you check the properties of the iTouch in Device Manager does it say it running correctly?

Ok I removed the rule - if this is correct, via Defence+ / Advanced / Computer Security Policy and the rules in Network Security Policy (?)
This doesn’t make it visible in Itunes.
I did, however, allow the new requests which came up although this is still not letting the device install! :frowning:

IN the properties of Ipod Touch in Device Manager, there is no information as the Device Driver has not been installed. Comodo must have blocked the initial install ?
It also says the Device is working correctly.

I think I know where the problem may be. When you first hook up a device its driver will be installed. As part of the driver installation there will be alerts from services.exe. When these alerts are blocked that will corrupt the driver installation.

Now look up the rule for services.exe in Computer Security Policy and choose to edit it. Then choose Access Rights. Look up Protected Registry Keys and push the modify button behind it. See if there are things blocked under the Blocked Registry Keys tab. When there are remove them and OK your way back to the main screen. Then try hooking the iTouch again.

Unfortunately, nothing is shown as blocked in the Blocked Registry Keys tab :frowning:
I removed services.exe altogether, hoping it would come up and ask me again however this didn’t work either!
I’m thinking I might have to uninstall Comodo, install the Ipod Touch, then reinstall Comodo again! What do you think ?!?

Before deciding to reinstall CIS try uninstalling the iTouch from Device manager. To do so right click on it and choose uninstall. Reboot in case asked to do.

When there was no reboot required let Device Manager search for new devices and see what it brings. Also keep an eye on the CIS alerts and to allow. When a reboot was asked I think Windows will start looking for drivers while booting.

:o OMG!! That has worked!! Something as simple as that!

Thank you SO much for your help :-*