Comodo blocking my NAS

I have synology NAS. But comodo firewall blocks it so I can’t access it from my computer.
But when making firewall inactive I can then access my NAS.

How can I add this nas so I can access it when firewall is active?

I assume the NAS is a LAN based device as opposed to being directly connected? If so, when you installed CIS did you receive an alert for newly discovered Network? If you’re not sure, please check the following:

  1. Open CIS
  2. Navigate to Tasks\Firewall Tasks\Advanced Settings\Security Settings\Firewall\Network Zones
  3. Report the Zones listed in a post here.

You will, in all likelihood, also have to turn OFF " Block fragmented IP packets" ( or similar wording - thats what it was called in 5.X) to get you NAS working.

This has needed to be done forSynology, WD, Thecus, etc. It also generally applies to wireless printers.

Hope this helps,
Ewen :slight_smile:

I found the network zone section but not here Tasks\Firewall Tasks\Advanced Settings\Security Settings\Firewall\Network Zones

What should I add in zone list? is it my NAS internal IP?

It sounds like you’re probably using version 5.x in which case the location of the components are different to that indicated above.

Before you add any new information to the Zone map, it would be helpful to know what you currently have by way of zones?

I think I have solved it.

On the comodo icon I right clicked → configuration and activated there comodo internet security. Before that comodo - firewall security was active.

I don’t really understand why this solved my issue. But it worked.

I’m glad you’ve found a solution but I’m curious, as changing from Firewall security to Internet security alone would make things more difficult. Perhaps, by making this change, the appropriate zone information was added.

Yes, when I done that I was asked to accept the zone verification.

And this works now.