Comodo Blocking My FTP Server[Resolved]

I just installed Comodo and it looks like a great firewall. I can’t get it to allow connections with my Cerberus FTP server even though Comodo has configured a rule to allow both incoming and outgoing traffic. If I turn on “Allow All” I can connect just fine. The server is being used in conjuction with DUC No-IP which Comodo has also been configured to allow. I know this must be something simple I am missing; can anybody give me some help?

You need to create a network monitor rule to allow incoming ftp connections.

To do so, goto Security->Network Monitor

Select first rule and right click on it. From the menu select Add rule->Add before option,

Action : Allow
Protocol: TCP
Direction: IN
Remote Port : Single Port, 21

Then press OK button and retry. If you FTP server listens on a port other than 21, you should change 21 to necessary value.

After this rule, it should work fine. But make sure your newly created is above the BLOCK IP IN FROM ANY TO ANY…i.e the last rule.

Hope this helps,

Ok thanks, After doing that it is able to log in but can’t find the directory on the server unless I change the “Block” to “Allow” in the IP rule below the rule I just created.

You may need to create a rule to allow in to your passive ftp port range.
You should be able to specify this in your FTP server config.

Alternately you should be able to get clients to connect using active mode.

You can do the following: Select “Create an alert when this rule is fired” option for the BLOCK rule. And then retry. After that CPF should show you what it is blocking at Activity->Logs section. If you can paste the logs, we can see what other ports you need to open.


By default Passive FTP uses a random port > 1023.
Unless you specify the range in your server first you basically need to open every port from 1024 - 65535.

Yes that makes sense. I created new rule for the passive port range and now all is well. Thanks to all of you.