Comodo Blocking Firefox (and won't stop it)

I have been using Comodo for about 2 weeks with no problems, a was still frequently getting pop-ups asking about other programs using firefox to access the internet (in particular when I installed something new). I was trying to install a program and it failed to install as I needed net framework 2 installed first. I denyed the program and now I can’t access the web with firefox. No matter how many times I tell comodo to allow firefox it simply won’t until I disable Comodo. I have tried deleting the firefox entry so that comodo asks me if I wan’t to allow or block, but this doesn’t work either.

I did some searches and it appears that others have had this problem and have stopped using comodo (usually switching to something like ZoneAlarm) because of this problem.

Is there a way to fix it???

Hi trenton24, welcome to the forum :slight_smile:

It sounds like you have inadvertently blocked firefox, by denying a prompt, related to the application. Try this:

  1. Open CFP
  2. Select Security\Application Monitor
  3. Check the ‘Permission’ column status on the right of the screen for Block
  4. Remove the block and try firefox
  5. Sometimes it’s necessary to reboot.


I have tried that (there was no block in the permissions column - however I ensured that firefox had permission), but I haven’t tried the reboot. Just buring a DVD at the moment so I will try as soon as that finishes.

A restart is what was needed, thanks mate

No worries :slight_smile: