Comodo blocked my flash USB and crashed explorer.exe

Greetings. I am a long time user of Comodo and especially of CIS Premium. Unfortunately I ran into a very annoying issue. Comodo blocked my flash usb whenever I plugged it, leading windows explorer into a crash and an 80% freeze of my pc from where I could only move the mouse but not shut down or reboot my pc (power buttons were not working), only hard reset it. Comodo blocked it even when I shut down all defences and closed the program. It worked only with Comodo removed completely from my system. I dont know why that happened but I had to uninstall your product and re-install it, which solved my problem (I hope permanently).

I am still using your product because I consider it by far the best security suite out there and I thought I had to report this bug. I use Windows 10 64.

Sometimes the device can be infected even without any unknown file in it and sometimes this happens due to the malicious file trying to recursive access to system files, security programs … or as it seems to be your case, just a corrupted installation Or erroneous previous setting.

I dont think there was a corrupted installation. Comodo was working perfectly and suddenly this happened without any notification from the program about the flash drive. Whatever, let’s hope it was a temporary problem.

Hello all, i have the same problem with the new Comodo 10. When i plug an USB flash or my external HDD, explorer.exe chashes, i can’t access my USB storage devices and i can’t even shutdown or reboot my computer. This happens in a virtual machine too. To solve the problem i need to remove Comodo. With Comodo 8 it’s all fine. I have Windows 10 with all the updates.

Please provide a diagnostics report.
main interface window > question mark (?) > support > diagnostics

I can’t install Comodo again, now it gives me the error 1603

in particular this removal tool

Guys, the problem was solved by reinstalling Comodo but now it is back. Once again, I cant plug any USB drive without problems. When I uninstall Comodo, there is no problem. With Comodo installed, 1/2 attempts to use a flash usb leads to hard reseting my computer. Also, this happens only with Windows 10 loaded. If I plug the usb drive BEFORE Windows 10 load, there is no problem.

My flash USB is not infected or corrupted.

Can anyone provide a solution, please, because I am on the verge of uninstalling comodo permanently.

Without a complete memory dump, issue cannot be investigated. Please create a bug report using required format.