Comodo Blew up my computer!!!

We’ve got an XP Pro computer on the domain here in the office. I thought I’d try out Comodo… installed it and tried to reboot, but it keeps resetting while trying to boot into windows! Safe mode doesn’t work, neither did Last Known Good Configuration. Also tried Recovery Console, and couldn’t figure that out.

Help!!! how do I uninstall Comodo and get my computer back!!??

This sounds like a driver/software conflict to me. Are there any other active security components (other firewalls, HIPS, etc…) running on that system?

Also, you said that Safe Mode doesn’t work. Why not? What did XP say? I ask since CPF doesn’t load in Safe Mode & this would be the normal procedure to remove such a component as CPF.

The only firewall the was on the computer before, was Windows Firewall… but since it was being locked out by a global policy, I didn’t think I could remove it before installing Comodo.

I’m actually not on location, I’ve got a guy there helping me. He says that whenever he tries Safe mode, it get’s to the windows splash screen for a second or two, then restarts the computer.

Window’s Firewall shouldn’t be a issue (I believe CPF disables it when it is installed). This is very worrying… there shouldn’t be any conflicts in Safe Mode (double check with your guy that he was using plain Safe Mode & not Safe Mode with Networking). Then again, the system is in corporate set-up with Group Policies… so, just about anything is possible unfortunately. Have you talked to the systems Admin?

I can give you instructions on how to remove CPFs service & driver from the recovery console (using listsvc). But, since I don’t have XP… these would be from memory & would probably need checking by someone who has XP before you use them. Do you want me to do that?

well, if you think that’ll fix it… sure, let’s do it.

Is this a time sensitive issue? If not, it might be better to wait for XP mod to drop-in (a maximum of 4 hours, I guess).

well, this computer IS using print and file sharing for the rest of the office (I know, I’m an idiot for trying out new software on THIS machine)… so we’d like to get it back up as soon as possible. But if you think it’ll help to wait for some XP mods then it can wait.


Sorry, I meant to also say… the instructions that I could give you will 100% cripple CPF by disabling its drivers & service. The only remaining element would be the Start Up registry entry that will attempt to run CPF.EXE on startup. CPF might fire up or even re-install its drivers & service because it might think it has been attacked. I’ve never tried it. But, I am not 100% convinced CPF is causing the problem, since it also happening in vanilla Safe Mode (is it?). So, I cannot be certain it will resolve the issue.

Edit: Is it? Of course! Can you boot the PC with it completely unplugged from the network & printer, isolated?

Yup, plain old vanilla “Safe Mode” was tried, and it was unplugged from the network.

The bad news is that the guy in the office has taken out the hard drive and plugged it into another computer in an attempt to get off the files he needed. It didn’t work, so now he’s plugged it back in and we’re getting nothing (it can’t find the hard drive).

So, either he’s put it back in wrong (very likely) or we have a case of coincidental hard drive failure at the same time I installed Comodo. (also possible, but odd)

Well… remote as it is… it is plausible (although your choice of subject is now… well… prophetic?). A reboot is when you first notice a HDD failure, they rarely fail in your face. Of course, there is a risk of handling/moving any HDD. Bent pin maybe? Does the other PC boot?

Also… I did say I didn’t think it was CPF. Sorry. :frowning:

thanks for the help anyway. I may have jumped to conclusions, but it was pretty odd that as soon as I install Comodo and rebooted, it never came back up.

We have a tech guy coming into the office to have a look at it. I’ll let you know the results.

thanks again.

Hi, sorry to jump in Kail. Actually , I see this all the time and have had this happen many times, the hard drive fails upon install of a program. Not uncommon. Why? Because if it’s failing you are using it and installing a new program which puts more strain on the failing drive. When it wasn’t recognized, I knew immediately it was probably the drive. When safe mode was doing as explained, I assumed bad sectors or head crash. In a work environment I would hope backups were made. As well, tell whoever doing this to use a knoppix cd to try and recover the failed drive information. Else it gets costly to take the drive in and recover the data depending on how important it is.


thanks Paul… makes sense. Actually going the Knoppix route was my next choice.

Yes, Knoppix can be a life saver but still not 100% effective. Make sure someone downloads it and burns it as .iso image so it’s bootable.


This indeed is a registry conflict issue with other software, ni idea which software, but it happened to me once, and the only way to repair the problem was reformatting the hard drive, unless you have a recovery consule diskette (which I did not) otherwise install your windows CD reboot, choose boot from CD on startup screen and click F2 to start automated system recovery.

Hi. Thank you for the insight but there is no way to say it is a registry issue. The problem lies here, if there are bad sectors on the drive, Windows will overwrite or “skip” would be the better term here, these bad areas, not repair them. After an install, the disk may run for a while, perhaps quite a while but expect not too far off that it will fail entirely or errors will keep happening. If the drive is no longer recognized and won’t get recognized, this is usually do to a major crash, not registry issue. If you get no OS found, then it may be a corruption. However, resetting the Bios may solve the detection issue if it is a different failure but rarely does it work. Especially in work environments, disks are under a lot of stress, the only thing that keeps the head from crashing is a pocket of air between the head and the platter from the RPMs it dishes out. I understand the methods of recovery, but if the drive isn’t recognized, they will not work which is why I didn’t bother myself to mention them. This is also why I don’t feel Knoppix will even do much good. If this is a registry issue, I would be extremely surprised. I am not doubting you, I just wanted to explain why I don’t feel it’s a registry issue.