Comodo bad_module error when running


I’ve been running into this error everytime I try to start Comodo:

Faulting application name: bad_module_info, version:, time stamp: 0x00000000
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000374
Fault offset: 0x00007ff9252d4d1b
Faulting process id: 0x2118
Faulting application start time: 0x01d414be47e52b8c
Faulting application path: bad_module_info
Faulting module path: unknown
Report Id: 0f956f59-4aab-40ad-9ea1-3621475dca70
Faulting package full name:
Faulting package-relative application ID:

cmdagent and cavwp still appear to be running in the background, but when I try to autostart Comodo I run into this error in event viewer. If I go to the Comodo folder and run the cis application, I am able to access Comodo. CisTray seems to be broken (since the shortcut whenever it crashes is linked to CisTray.exe) And well I like having my tray icon for comodo there haha. Just wondering if anyone had any ideas on why I get this error or any fixes in regards to this? (This probably happens a few restarts in after reinstalling Comodo). I have already reinstalled Windows 10 (build 1803), reinstalled Comodo (and uninstalling using the forum provided full uninstaller), running dism commands, sfc commands and chkdsk with no avail.


Hi Kimchighost,

Can you please provide the logs requested through Private message(PM).
Thanks in advance.

Kind Regards,

Exactly my error / problem also.

I think Comodo team found the cause of the problem today, using Team Viewer session in my pc.

So a fix will be introduced later this month. So i’ve been told.


I went ahead and sent both to you PremJK, thanks!

Oh shoot okay glad that they narrowed it down Pixo1. I thought it was either a BIOS change on the motherboard level because well it just hit me that was something I changed with my x’ed reinstallation of Windows 10 or some Windows update causing some sort of group or local policy change since runtimebroker was throwing out dcom errors and not given specific permissions.

I miss windows 7 hahaha.


So after a restart I noticed that the bad_module error is gone and the tray is back and event viewer is now throwing any errors out anymore.

One thing I noticed before restarting was that “Windows Operating System” was blocked and 3 network intrusions from the same IP which was from Google (had to do with Youtube/Google and some other Google domain related names) during the same time.

After unblocking “Windows Operating System” from the “Blocked Applications” list and doing a restart, Comodo was back to normal.

Thoughts? Coincidence? Is “Windows Operating System” not actually the OS but some random application masked as the Windows OS and Comodo was just doing a blanket block on that application since my computer was just idling during the time?


Sorry for the OT. I think this “Windows Operating System” should be a bit improved. Clearly it is not Windows but some masked application.

Allowing it to receive or send information is a security risk, because you don’t know WHAT application is doing that. This has been posted before, and if i recall correctly Comodo has answered that nothing can be done. Still …

Can you try a clean install of the latest beta to see if you still this issue after installing and rebooting?

Hi, same problem here, installing beta did not help. :frowning:
Running Cis manually says that everything is ok, but cistray is not started and there are absolutely no popup alerts, so it is unusable now. :frowning:

Any progress on this problem? At that time I “somehow” solved it by switching FW and HIPS off, restarting, unblocking applications, etc. Don’t know exactly how it happened but it worked since that. Few days ago I updated to and the problem appears again >:(. I cannot find a way to make it working again… :frowning: Windows event viewer there are two types of errors - one with bad_module error and one that CisTray failed in module ntdll.dll. Would WER crash log file help in any way?

Yes and any crash memory dumps from ProgramData\Comodo\CisDumps

Here it is: