COMODO BackUp 2.0.105890.7 RC4 BUG REPORTS

Please post all bug reports & BSOD’s here.

Be sure to include:

  • Your Operating System (and whether it’s 32bit/64bit);
  • Other Backup & Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files;
  • Any other Additional Information;

I created a batch file to remind me to connect an external USB drive prior to a scheduled backup running. The batch file ended with a PAUSE statement, thereby allowing me to connect the drive and press a key before the backup ran.

I assumed that CBU2 would execute this file and wait for it to terminate before the backup would run. Unfortunately, CBU2 executes the file and then immediately runs the backup. This results in the backup failing with an error code 46 (assuming this is “Destination drive unavailable” or similar).

Is this how it is supposed to work?

I would have thought that including this option meant that the named app would execute and complete BEFORE the backup would commence. If the backup isn’t going to wait for the named app to complete, why have the option? I really can’t think of a reason to have this option there if CBU2 doesn’t need the end result of the app executing.

Your Operating System (and whether it’s 32bit/64bit)
Windows XP SP3 fully patched

Other Backup & Security Software Installed
CIS 3.10, CTM pre-release

How you produced the problem
Added a task to be run before a backup. Task was correctly executed but Backup started before task was completed (failed with error code 46)

How you tried to resolve the problem

Screen-shots with the error (if any)

Post Memory Dumps on crash if you encounter any

All log files
05.08.2009 07:07:51 Running scheduled backup Z:\test.cbu
05.08.2009 07:07:51 Running task before backup “C:\Documents and Settings\Ewen\Desktop\docs_bu.bat”
05.08.2009 07:07:51 Creating New Backup…
05.08.2009 07:07:51 Error Occurred
05.08.2009 07:07:51 Backup process failed with code 46

Any other Additional Information
This also occured in RC3 but I only found this just before installing RC4.

Ewen :slight_smile:

Clean install of RC4

Vista x64 SP2
CIS - no other backup/security software active. MBAM and SAS installed but on-demand only
Same issue as with RC3.

For a recap, please see;msg307579#msg307579

Edit : included link for clarity

WinXP 32bits

Many times I get a blank panel message with YES or NO. Let’s say I start the process of creating a backup and when it ask for destination I go press another button like Settings, I presume ha ask if I’m sure I want to cacel what I was doing but I get this :

Same if I press look for update :

Have to wait for RC5 or a quick update will be available?

Is it normal the sync mode will sync every specified minutes no matter if files were odified or not? It was not like this in v1 and I really don’t want this.

Also when I click the backup file (which is a .cbu file) I was expecting a kind of explorer-like windows that show the archive structure and that I would be able to select a single file or a few to restore. What I discovered is that it ask for a clear backup or append. What’s that?

I still prefer how v1 works yet (except delete propagation is missing)

Finally, why are we looking at RC instead of BETA? We usually not see so much RC before a final version, or am I wrong?


Thank you for reporting this problem.
This is not how it supposed to work :slight_smile: .
The issue will be fixed in the next release.


So far, we could not reproduce this problem.
We need more details in order to reproduce this.
Please tell us:

  • resolution and DPI used
  • what videocard you have
  • complete list of installed programs

Thank you

It asks for a “clean” or “append” restore.
This is the restore method.
A “clean” restore means that all files and folders in the restore destination are deleted, then the restore process takes place.
An “append” restore means that the restore is performed without deleting the existing files & folders in the restore destination, but restore overwrites the files that have the same name with the ones stored in the backup file.
In the next step (restore step 3) you can select one, a few or all files to restore.

1600x1200 on a 8800GTS
French WinXP 32bits, Backup installed in english (since no french yet)

Any easy way to list all installed programs?

I see… I quit just before that step. Any chance to see a CBU Explorer similat to Ghost explorer (I don’t know if you know what I mean)?

And if I tell to backup every minute, will it backup every minute even if no modified file or it will works just like in v1?

If you have defined a scheduled backup you cannot later edit all the parameters used when setting the job up (e.g. - add a macro to a scheduled job and the only way to change the selected macro is to recreate the job and delete the original).

When defining a scheduled job, wouldn’t it be better if we were able to give the job a “friendly” name, rather than the filename being the job name?


Control Panel->Add or Remove Programs, hit ‘Print Screen’ key to capture the screen.
Then, post the picture with installed programs.

Yes, the backup will be done every minute.
In a future release we will add a verification to see if any changes occurred on the source side.

We will take that into consideration.

Thank you.

After extensive testing, we were able to reproduce this bug.
So, it will be fixed in the next release.

Thank you.

Time ago, I posted an issue because I couldn’t schedule a backup no matter which version I used.
I discovered what caused this issue. The reason was because Windows task scheduler service was disabled!!! :o
I have activated it using xp-Antyspy and everything works fine now.

This topic has been locked