Comodo application agent not running

Sometimes when I start my computer, my LAN delays in acquiring the IP and Comodo takes a lot to initialize and when it finishes it it displayes this error (see screenshot)

If I run the Diagnostics utility I find no problem.
If I exit firewall and then open it again, the error disappears and everything is running ok.

What should I do to prevent this from happening?

[attachment deleted by admin]

No idea here ?
It happens once at 3-4 restarts.

It seems this have been fixed with the latest CIS Beta version.

I got this error again. :frowning:

Why isn’t anybody looking here ? (:AGY)

Try reinstalling Comodo. Reboot and delete all folders related to Comodo Internet Security. Then let a thorough registry cleaner clean the registry. You can try Comodo System Cleaner: .

I am having the same problem plus CPU usage seems to be higher (it is really higher w/ Firefox - something else I need to look at). The Application Agent not running just started in the past week or so. I am at .439 which I think is the latest, I am concerned not having firewall. What is the solution and what introduced this problem of the firewall not starting.

Also tells me to run Diagnostics which I do but tells me there are no issues.

Today mine has done the same for no reason. Unistalled, ran CSC, Reinstalled still no luck nothing in it will work FW,AV,+D. :frowning:

The latest beta has version number .459: . Try installing it and make to sure uninstall 439 completely as I described in the above.

Nope still the service wont start. Ill put avast back on and webroot Fw and wait for the 3.8 final.

EricJH, I did as you suggested and after 3 restarts everything seems right, but… you can never know. :smiley: