Comodo application agent is not running

Comodo has an exclamation mark on the tray icon and in status says that the application agent is not running, however when I run the diagnostics as requested it finds nothing wrong with the system, and if I look in processes cmdagent.exe is running. It started doing this is the past week or so.

Do I need to be concerned?

(I am fully up to date according to the updater)

That is my issue too.I use laptop with centrino duo 1,76ghz and 1gb RAM. It does not comes up all the times but it does so.

Can you check with Task Manager to see which of the two following applications are running:

You need to enable “Show processes of all users” in Task Manager.


I am also having this problem, but am adding my “me too”-like post here since I am in perhaps a better situation to help solve this problem.

I have just installed a fresh Windows XP SP3 system (via a basic installation and with a step for SP2), a fresh installation of CIS 5.5 (195786.1383), and nothing else. I haven’t even updated all the post-SP3 Windows Updates yet. The only updates that have happened are COMODO’s antivirus definitions.

I installed the Firewall and the Antivirus, but not GeekBuddy, of the free CIS product. Windows Firewall is off. Windows Security Center reports COMODO and only COMODO for both firewall and antivirus, and both say “on”. So there is certainly no clash with other AV products, security programs, etc.

Task Manager shows both cmdagent.exe (as user SYSTEM) and cfp.exe (as me, the only user apart from the in-build Windows “Administrator”, and so I am an administrative account). Diagnostics “did not find any problems with your installation”. Checking for program updates says “product is currently up to date”.

I will be doing the outstanding Windows Updates next, and there will be reboots each day anyway, so I’ll see if it is intermittent or if some update solves it.

Thanks in advance for any suggestions.

Thank you for your reply Rob. That shows the problem is not in used utilities but some place else. May be a conflict with a driver of certain pieces of hardware like a Network adapter f.e…

If you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Out of sheer curiosity. What network adapters, both wired and Wireless, are all of you using?

On restart today, CIS is happy.

Regarding network adaptors, at my level of hardware experience, I see an Ethernet port (not used) and my Android smartphone acting as the internet connection and connecting through USB.

However, the complete list of all network adaptors, from a hardware report file I’ve generated, is:

  • 3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible)
  • WAN Miniport (L2TP)
  • WAN Miniport (IP)
  • WAN Miniport (PPPOE)
  • WAN Miniport (PPTP)
  • 3Com 3C920 Integrated Fast Ethernet Controller (3C905C-TX Compatible) - Packet Scheduler Miniport
  • WAN Miniport (IP) - Packet Scheduler Miniport
  • Android USB Ethernet/RNDIS - Packet Scheduler Miniport
  • Direct Parallel
  • Android USB Ethernet/RNDIS

If you want all the info associated with any of these, let me know.

Edit: Created bug report as requested:

Both processes are running. By the way this happens some time through the day. It is not there at startup.

So why would there suddenly be a problem with a driver/network adapter when Comodo has been running fine for weeks on end? The thing is that both processes are running OK, it is just the tray icon that seems to have problem! The diagnostics find nothing wrong.

System resources report attached

[attachment deleted by admin]

The error appeared again today. I’m in the middle of installations and upgrades, but here’s what I remember which I think might be important (based on the assumption that actual applications used is not a factor):

I had upgraded Firefox from 5.0 to 6.0 and was installing Winamp, which informed me that there was an update for that. So I clicked on the button to download the new version. That should have brought up Firefox and presented me with Winamp’s home page, but Firefox did not appear, although it was running - I could see it in CIS’s Firewall pane.

Eventually I gave up (this is a slow machine, but I left it long enough), and so closed everything and restarted, assuming that either Firefox 6.0 was misbehaving with CIS, or there was some issue with Firefox 6.0 and the add-on “NoScript” which I use. The aim was to go directly to Winamp’s web site after the restart.

Upon restart, the “COMODO Application Agent is not running” thing happened. Defense+ then came up with an alert about Firefox wanting to access a DNS thing - presumably it’s not in your trusted cloud list yet - which I said to allow and to send COMODO files.

I checked Computer Management’s Event Log, and there seems to be nothing in there that was unique to that startup, certainly nothing from CIS directly. I also browsed the COMODO “Program Files” and “All Users”'s “Application Data” folders, and didn’t see anything which looked like some kind of error log.

When this happens again, is there anything I can look for?

Anyway, I tried Firefox again, and it started ok, and was able to acess Winamp’s web site and download the new version of it ok. Upon then restarting again. CIS’s “not running” error was gone.

My thoughts?

The first time this happened with me was just after it had been installed fresh. Perhaps something to do with cloud access or handling applications which have not yet been approved?

A race condition with the processes you asked us to check for, where they are having to do alot upon startup and so are not able to respond to the main application, which then thinks they’re not running?

And a suggestion…

When the diagnostics are run, clear any alerts which are going to be rechecked, and reisse the alert if the error condition is subsequently found. That would clear what seems to be happening here, where all’s fine but the error is being reported and can’t be cleared.

Please file a bug report Rob. That is the only way this problem will get fixed.

If you are a chip of the adventurous block you could try the latest beta of v 5.8 and see if that brings solace here.

I did file a bug report, here, a week ago, after it was originally suggested:

I didn’t post the above description of events to that topic, since that forum seems to be alot more controlled and so didn’t think it the right place for that free text. However, I can easily repost the text onto that bug report topic if that’s ok (or a moderator could just move the post, perhaps?).

The next machine I set up I’ll try the latest beta.

I too for about a week now have had the same ‘Application agent not running’ error message appear every time I start windows 7 ultimate, I found however that if I simply select exit on Comodo’s taskbar icon and wait for about a minute then restart Comodo IS from the programs list, everything reports as normal thereafter. However I am concerned that I have to disable anti virus and firewall, just to clear this error. It seems to be the only way to clear the problem.

After restarting Comodo, I receive another message saying I haven’t completed a full scan yet, however I have only just recently completed a full system wide scan a couple of days ago. I seem to receive this notification every time I update Comodo IS.

I have not changed any hardware nor have I updated any drivers recently. So I am completely clueless as to why this problem continues to occur.

Can anyone shed some light on this issue, as I would hate to have to find an alternative to Comodo, as it’s been so consistent and reliable up until now…

Closing CIS from the tray only closes the client. Normally Comodo Agent would still be working and protection would still be in tact.

Best thing to do is to see if Comodo Agent is running. Check with Task manager to see if cmdagent.exe is running. Make sure “Show processes for all users” is enabled in Task Manager.