comodo application agent is not running

“comodo application agent is not running” thats what it says
using 64-bit version
tryed diagnostics [1* found nothing], tryed copying program files from another computer[1* it happened again], re-installed[2* just happened again].

system specs
windows 7 ultimate 64 bit
amd athlon x2 5000+ 2.20GHZ dual-core processor
4GB ram
500gb sata HDD in AHCI mode
diamond radeon hd 5670 pci-express 1GB graphics card
diamon PCI sound card
msi a785ge motherboard
650watt visiontek PSU

OEM driver programs from discs
open office
opera internet browser
orbit downloader
mozilla firefox
interent explorer 9
utorrent(don’t use it often haven’t used it recently)
comodo time machine
comodo system cleaner (disk cleaner only no privacy or registry cleaners)
gmote server (to use my phone as keyboard and touchpad)
windows live mesh
world of warcraft client
curse client
vindictus client(mmo game)
plants vs zombies
windows media player
zoom media player
vlc media player
combined community codec pack

1* = widnows security reports it as offline
2* = windows security center isn’t reporting any issues involving comodo
checkdisk was run pre-reinstallation

now given all that why is this still happening? ???
attached is a hijack this logfile

update: terminated cmdagent.exe (disabled defense+) then started it again and did the same for cfp.exe appears normal now. this is further baffling me ??? ??? i’ll try just re-starting cfp next time it hapens.

update2: it appears when this happens and it isn’t reported as offline terminating and re-starting cfp.exe will clear it (side note: my diamond radeon hd 5670 is giving me grey-screen possibly related[googled and third party driver interaction could cause it and the whole issue with gameguard and defense+ way back left no logs soo…] and no third party driver except sound card graphics card and comodo[the kernel driver])

[attachment deleted by admin]

What is curse client?

What does this Active X entry belong to:

O16 - DPF: {4944924A-64E4-49C1-AC97-ABA3927262FE} (StWbUsa Control) -

curse client is and add-on manager for world of warcraft

well looking at it it looks like an entry for an in-broswer launcher(some online games will launch from a browser window rather than a direct launcher and/or patcher) for an mmo (i’ve played more than a few in my day).
keywords being dontblynk (played an mmo from them once) and launcher

The HJT log is not ringing alarm bells with me. I see you updated your post and are mentioning Game Guard protection. That may be the cause here.

The only way to find out is to disable or uninstall Game Guard and see what happens.

no gamguard installed just using it as an example. see a while back a version of gameguard caused a reboot when it interacted with defense+ just wondering if maybe something else could be mis-interacting with comodo and somehow causing this result. the gameguard comment was just an example of a time when something caused a problem but left no logs to indicate where the problem was

I’m having the same problem, and, believe me, I know how to read a Hijack This log. There’s nothing on my machine that’s even capable of blocking application agent from launching, much less actually doing it.

Others have complained about this symptom. When is someone from Comodo going to jump-in to the conversation, admit that there’s a bug, and give us a promise that it’ll be fixed?

I am having the same problem. The issue started when I updated to the latest version to get rid of the annoying new version reminders. I am on XP SP3. I have tried unintalling/reinstalling at least 5 different times. There are no updates to the version (at least that is what the check for updates states). When I boot it take about 3-4 minutes for it to fail and then I can access the Internet with other apps such as Chrome or AVG. Is there anything else to try to resolve this. (I did not install the Geek Buddy on this installation at any time. Could this be the issue?)

Current versions of AVG and CIS don’t always seem to cooperate nicely. Does uninstalling AVG bring a solution here?

First noticed this same problem upon rebooting Vista Home Basic SP2 today after Windows updates, and also application updates to QuickTime (version 7 to a later version 7) and to SUPERAntiSpware Free (a version 4 to a version 5, note that there are no monitoring options in this free version). I don’t have Windows Firewall, AVG or any other malware monitors running (I have MS Windows Defender, but its monitoring is off). The relevant Comodo v5.5x processes are running, and the recommended Comodo diagnostics finds nothing. Comodo is up to date. I have not tried to fix this problem, hoping that Comodo will find a bug in their software first. Probably not a high priority for Comodo though, as Comodo seems to be running normally except for this (hopefully erroneous) warning. I noticed that a reviewer of Comodo 4 Beta experienced this same problem on a clean system back in January of 2010:

I did get one unusual Comodo alert, however, while running the above updates–Comodo asked me if i wanted to allow SpeedFan to access my disk. I use SpeedFan to monitor fan speeds and component temperatures (including hard disk temperature) so i agreed to this request, and let Comodo remember my answer. It seemed unusual though that Comodo hadn’t asked me about this before, as I’ve had Comodo and SpeedFan running simultaneously in my Windows Notification (“System”) Tray for months. If during subsequent scans i find any malware associated with the name “SpeedFan”, i will be sure to post back here.

I’m using the free version of CIS, with the default ProActive Security Configuration.

Has any industrious person bothered to complete a bug report on this issue? Instructions at:

I would like to invite everybody who has a problem with cmdagent.exe not running to make a bug report about it. There may be multiple underlying causes to this event.

When cmdagent.exe crashes when scanning, it will then stay at one file and won’t continue, also follow How to determine which file is causing a manual scan to hang to determine what file was causing the scanner to be hung. Please add this information to your bug report.