Comodo Application Agent is not running

Sir,

I upgraded to Ver 5. When Comodo comes up, it shows an error message. In the diagnostic section it says “Comodo Agent is not running”. I run the diagnostics and it tells me that there are some errors. I approve for Comodo to check them and it tells me that it has cleared the errors. However, the error mark still shows and the message shows as before.

How do I get rid of it? Rebooting just repeats the above cycle.

I run Windows XP prof. and use bit defender for virus protection.

Help!

Peter
10/14/2010

Look in you windows event log.

Easier solution
If it shows that the CIS helper service is timing out then look for the CIS Helper service in Start ~ Admin tools ~ Services.

Open it, on the recovery tab change at least the first failure setting to ‘restart the service’. You may need to play with the ‘restart after’ setting so the restart occurs at a time of low processor usage. Then reboot the computer.

This may or may not work, but there’s a good chance it will!

Less easy solution - only do this if you know how and make a system restore pt first.

Create or edit the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ServicesPipeTimeout to have a value between 40000-60000. (Choose the lowest that works).

To create this registry entry, follow these steps:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. Right-click Control, point to New, and then click DWORD Value.
  4. In the New Value #1 box, type ServicesPipeTimeout, and then press ENTER.
  5. Right-click ServicesPipeTimeout, and then click Modify.
  6. Click Decimal, type the number of milliseconds that you want to wait until the service times out, and then click OK.
    For example, to wait 60 seconds before the service times out, type 60000.
  7. Quit Registry Editor, and then restart the computer.

(Will not be present in forums for a week, but hopefully someone else will answer if you have any queries).

Best wishes

Mouse

I get the same error notification but CIS does not find any errors after diagnostics. This occurs every time XP starts. Any ideas?

What version of CIS are you using? Is this an upgrade or clean installation?

I’m using the latest version of CIS and I can’t remember if I upgraded or did a clean install.

Do you have other security programs running in the background? If so try disabling them see if that helps or not.

May be left overs of previously uninstalled security programs are acting up. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

Only using CIS. Tried the above fix but didn’t fix the problem.

hi,

i am having the same issue. i downloaded the latest version and made a clean installation. i have no other security programs. i have tried all of the above nothing work.

kindly inform me with any ideas as soon as possible.

This could be caused by malware. Do a scan with MBAM and report back if it found anything.

Does running the diagnostic show any problems?

Which security programs have you had installed in the past? It could be remnants of those that are causing the problems?

I recommend you guys to reinstall it and use the CIS clean up tool after uninstalling CIS in safe mode.

Install CIS 5.3 as admin.

Regards,
Valentin N