Comodo Application Agent is not running

In the Status section, it has a big red X and says “Comodo Application Agent is not running. Run Diagnostics utility to fix the problem.” I clicked the “diagnostics” and it said nothing was found wrong. Now what? I just installed the Comodo Firewall yesterday. What does “Application Agent not running” mean ?

I cannot explain but I saw the same thing myself on a machine just upgraded to the latest version.
I fixed it by Stopping (right click Exit) Comodo and restarting it from the start menu.

I don’t understand “Stopping (right click Exit) Comodo”. I opened Comodo , but when I “right clicked” my mouse, nothing happened, no popup menu for exit appeared. “Right click” on what? I turned Comodo off and restarted it from the Start menu, but I still got the warning “Comodo Application Agent is not running”. Thanks for trying to help, but I don’t understand the first part of the directions.

Looks like the service “Comodo internet security helper” is not started (correctly) on system startup.
Can you check your services to see if it’s started “Automatically”.

And also check you windows eventlog, system to see if there is any warning/error in it ?

:-TD I give up on Comodo ! :-TD I spent almost all day today trying to fix the “Comodo Application Agent is not running” problem. I deleted Comodo from my computer, reinstalled it again (with the required Restart for everything) and still had the same “Comodo Application Agent is not running” message the second time. The heck with Comodo, I deleted it and got another firewall ! :-TD >:(

Hi all

I’m a newbie to Comodo and had the same problem. A search came up with this post in the forums….and it worked for me. Thank you jrdorock

https://forums.comodo.com/help_for_v3/summary_system_status_comodo_application_agent_is_not_running-t16841.15.html

posted by jrdorock

I got the same problem and I fix it following the steps bellow:

  1. Run services.msc
  2. Right click on “COMODO Firewall Pro Helper Service” and choose properties
  3. Select “logon” tab and enable the service for the hardware profile
  4. Select the general tab and start the service
  5. Go to directory “C:\program files\COMODO\Firewall” and run cmdagent.exe
  6. Close CFP on tray and start it again

Some kind of glitch. I checked it and found that even though it said App Agent wasn’t running, it was. Did this by looking at what was running and checking the services. All settings were fine and the agent file was active. So I did the exit and restart thing from above and it cleared. Just make sure you turn off your connection before dropping your guard. Mines a button on my modem (nothing like a hard break to be sure.)