COMODO Application Agent is not running under vista x64 (fix)

Hello everyone,

I decided to post this up after my experience w/ this issue. Comodo used to work fine until now. I don’t know if this is relevant, but it happened after I installed Crysis Warhead.

Here’s what happened to me:

  1. I turned on my pc.

  2. The COMODO Application Agent stops once you’re at the desktop. I had a pop up from the system telling me the program was not working. It gave the option of closing it or search for a solution. I tried the “search for a solution online” and it didn’t find anything.

  3. Tried to restart the system - it didn’t work.

  4. Went to the services (right-click computer icon->manage->services & applications)

  5. The Comodo service was set to “manual” and was stopped - changed it to automatic and started the service.

  6. Quit comodo, re-launch it from start-up menu->all programs.

  7. All good!

Hope it helps…

System specs:

os: Vista x64
cpu: intel Q9550
mobo: EVGA 790i ultra SLI
ram: 4gb
antivirus: avast 4.8.1335

Good solution. I will try to keep it in mind for when I see related topics.

Are you sure if happened after the installation of Crysis? That would mean CIS seetings can be changed and that would be a security risk .

Can you see if the Comodo folders are under My Protected Files? If so then I would like to ask to uninstall Crysis, reboot and install it again and see if the problem occurs again.