COMODO Application Agent is not running error


I just installed Comodo firewall yesterday and keep getting this error after 10 or so minutes of my PC being online. I have tried reinstalling but it didn’t fix it, the only solution I have found so far is to stop Comodo firewall, exit the program and restart it, but I’d have to do this everytime I turn on my PC. I have it running with Avira antivirus, are there any other solutions to solving this problem?

I am also having this issue
a month ago I installed v 4.1.150349.920 Internet Security Premiun addition
since then I have had error on startup
CMDAgent.exe - exception unknown software exception (0xc0000417) occurred in the application at location 0x00436704
I have tried other ‘fixes’ from the forum including atarting in safe mode and allowing system full control of comodo, and run services.msc enabling the hardware profile
but nothing is working
is there a bug fix for this new version or should I just uninstall

Try this goto Comodo main screen and click on the More… Tab top right corner, and look for Diagnostic click on that this might repair the problem.

I have the same problem. I run Diagnostics and it says it is fixed but must be restarted. When I restart it never completes initializing.


[attachment deleted by admin]

I’m having the same problems as the others in this thread. In the past couple of days I did the upgrade to 5.0.----- and ever since I’ve had this problem. I run the diagnostics then it makes me reboot. That doesn’t fix it. Task manager shows cmdagent.exe’s user name to be SYSTEM.

I don’t know whether I’m protected or not.

Is there a way I can go back to the prior version of COMODO? I don’t like this problem.


Hi there,

I did have the same trouble, with this new version of Comodo Firewall, when you are running Diagnostics and pop-up is asking to restart, the solution might be in fact not to restart…; ;D

Now, Windows looks a bit slower to open with this new revision, COMODO Internet Security cmdagent.exe might try to start services but can’t, as when you press:

Start -----> Configuration settings -------> Administrative tools --------> Services, you will see a COMODO Internet Security line, and cmdagent.exe should start automatically the service but don’t. A temporary solution I am doing now is to do it manually, waiting the dev-team to find a nice fix.


Thanks for your comments, but what I want to know while I’m waiting for the bug to be exterminated is: am I protected now? Or do I need to go back to zonealarm, which I left recently to come to comodo?


Patrick good morning,

if you are opening COMODO then go to Diagnostics, repair the troubleshooting, normally it should tell you that all systems are active and running. I would suggest not to restart.

Then if everything is “green” go to

This is a really good guide done by Chiron I am following: Install & Configure Firewall (5.0 / 2011) for Max Protection & Min Alerts

If you still have doubts after everything is tuned as per Chiron comments, you may go to this page and do some testing:

Note that at the moment, you will have to do the repair in Diagnostics everytime you are rebooting your computer waiting the fix, or maybe someone in the forum might have a better idea… ;D

My own opinion is that I shall not change my actuall COMODO firewall, just waiting the fix. :wink:

Wish it helps.


:(I have a better idea; find s program that does not give false indicators such ad this. I use Zone Alarm for years and never had any troubles and now comodo wants 19.95 to fix their problem. do not know what you are going to do but I am going somewhere else. Probably back to ZA.

They Should fix their problems not me have to find a work-around this has been going since ver. 4.0

you have such a nice programs and so many potencial buyers like me i was one klik away to buy that product when the same thing happend to me with the agent and that makes me to hesitate to buy it. Why not concetrate in this problem to fix it permenatly ? you make me use a difrent software much more worse becouse of this and the funny thing is after that is not load and you refuse to run the dignostics you can load it nicely. so one solucion is to get that agend off the load proccess or FIX IT . how hard is to find a bypass or to fix it??