Comodo antivirus reports it is out of date in Windows XP

Two days ago I had a red shield from Windows Security stating Comodo Antivirus is out of date. Comodo version is Internet Security Premium
When I try to update Comodo , there is an error against ’ Install signatures’. This is the first problem for a long time.

May you please share update settings as shown in enclosed snap?


There was only one file beginning with ‘b’ which was bases.cav I deleted this and updated but still get error . I have attached details of scanners directory

Try looking in C:\ProgramData\Comodo\Cis\signatures and C:\ProgramData\Comodo\Cis\signatures and C:\ProgramData\Comodo\Cis\wpTemp and delete any files with a .cav extension.

I don’t have any of those directories on my computer

You need to show hidden files and folders enabled using folder options from control panel to browse to the programdata folder or you can go to start and paste in this path to open the directory: C:\ProgramData\Comodo\Cis replace C: if it is not your main drive letter.

My system is already set up to show hidden files and folders, which I have just confirmed. Perhaps the path is different.

Win XP hasn’t ProgramData folder. It appeared since Vista.
On WinXP it looks like
c:\Documents and Settings\All Users\Application Data\Comodo\Cis\

It won’t allow me to delete it even after closing Comodo

What message do you get when you try to delete?

How do you close CIS?

I right click on Comodo icon in tray and exit. I get windows message 'cannot delete, access is denied ’ when trying to delete b0028711.cav

Judging by the number that is most likely the database file that is in use. You can check the version number under About (push the questionmark, ?, at the bottom of the CIS interface). If the database number is 28711 then you should not try to delete it.

When you disable from the systray it will only close down the systray and client (cis.exe) processes. The underwater process cmdagent.exe that does the work of protecting still runs.

Could you show a screenshot as umesh requested?

What screen shot do you require ?

I have attached update settings

Your update settings are ok. Did you by any chance adapt the hosts file for beta testing of CIS?

No, I haven’t done anything.

Is this of any use in diagnosing problem ?

Can you please try to change address to “http” rather “https” and try?


I have changed to http and still get the error