COMODO Antivirus for Linux 1.0.220659.32 BETA Released!

Hi Flykite,

I ran “yum install kernel-headers” which installed 3.1.9-1.fc16.i686 kernel headers.
I then ran /opt/COMODO/post_setup.sh, which told me I need kernel headers 3.1.0-7.fc16.i686. I “yum install” it [i]but was told that no such package was available.
Edit : I forgot a ‘-’ in my script, after running the correct one, I’m told on the contrary that kernel headers 3.1.0-7.fc16.i686 is already installed. But CAVL GUI keeps telling that filesystem filter driver is not loaded.

NB : I run fedora in VirtualBox ==> could this be the source of the problem?[/i]

Please support RHEL6 … It’s been out for a while and we’re moving in that direction quickly…

I tried to install CAVL on opensuse 12.1 and can’t proceed further than the image below shows.

[attachment deleted by admin]

I use Kubuntu 11.10

I dont install comodo 64 bit.

is this mail gateway thing coming to the windows version and will it be an optional component to install

It’s in linux version because mail servers are usually based on linux. I’m prettu sure it won’t be implemented to windows version.

Had to reinstall Ubuntu on my laptop so I installed 12.04 Alpha and just gave Comodo AV a try, seems to be working ok. I was able to install, run the terminal command, update and full scan, no problems.

Works ok in Ubuntu 32 bit.
Antivirus for linux it’s a good idea but I think it would be more successful if it contains a firewall because:

-linux is presented as virus free OS, but u still need a firewall;
-there is not a software (free) that contains antivirus and firewall;
-Firestarter was a nice firewall but no more new release (last was in 2005) and is not working good in Ubuntu 11.10.

People from Ubuntu begin to fix mistakes is likely 12.04 to be a success so Comodo must be in Ubuntu Software Center.

Linux has IPTables. Comodo could perhaps work on a front end for IPTables.

+1 to xRogue’s comment

+1 to xRogue’s comment [quote author=xRogue

+1 :-TU

I’m sure inbound protection is strong in Linux but not sure regarding outbound access. Would like CAVL (inc. firewall) to prompt for applications that require access to the internet.

:slight_smile:

The dream would be a full Comodo Internet Security for linux (CAV, FW, Defense+ and Sandbox). :stuck_out_tongue:

Can anyone tell me why I am getting the following error in Xubuntu 11.10:

admin[at]ned-desktop:~$ sudo sh /opt/COMODO/post_setup.sh
-e
COMODO Antivirus for Linux 1.0

-e
End User License Agreement

-e
Please review the end user license agreement.

-e
Press Enter to display it.

Do you agree with this license?[Y/n]: y

-e
Free Registration

-e
Receive the latest COMODO products news, updates and offers
COMODO will NOT share your information with any third parties.
Please input your email address(optional):
/opt/COMODO/post_setup.sh: 226: APP_LANG[0]=Portuguese, Brazil: not found
/opt/COMODO/post_setup.sh: 227: APP_LANG[1]=Bulgarian, Bulgaria: not found
/opt/COMODO/post_setup.sh: 228: APP_LANG[2]=Chinese, People’s Republic of China: not found
/opt/COMODO/post_setup.sh: 229: APP_LANG[3]=Czech, Czech Republic: not found
/opt/COMODO/post_setup.sh: 230: APP_LANG[4]=Dutch, Netherlands: not found
/opt/COMODO/post_setup.sh: 231: APP_LANG[5]=English, United States: not found
/opt/COMODO/post_setup.sh: 232: APP_LANG[6]=Estonian, Estonia: not found
/opt/COMODO/post_setup.sh: 233: APP_LANG[7]=French, France: not found
/opt/COMODO/post_setup.sh: 234: APP_LANG[8]=German, Germany: not found
/opt/COMODO/post_setup.sh: 235: APP_LANG[9]=Hungarian, Hungary: not found
/opt/COMODO/post_setup.sh: 236: APP_LANG[10]=Italian, Italy: not found
/opt/COMODO/post_setup.sh: 237: APP_LANG[11]=Polish, Poland: not found
/opt/COMODO/post_setup.sh: 238: APP_LANG[12]=Portuguese, Portugal: not found
/opt/COMODO/post_setup.sh: 239: APP_LANG[13]=Russian, Russia: not found
/opt/COMODO/post_setup.sh: 240: APP_LANG[14]=Slovak, Slovakia: not found
/opt/COMODO/post_setup.sh: 241: APP_LANG[15]=Spanish, Spain: not found
/opt/COMODO/post_setup.sh: 242: APP_LANG[16]=Swedish, Sweden: not found
/opt/COMODO/post_setup.sh: 243: APP_LANG[17]=Turkish, Turkey: not found
/opt/COMODO/post_setup.sh: 244: APP_LANG[18]=Ukrainian, Ukraine: not found

/opt/COMODO/post_setup.sh: 251: Bad substitution
admin[at]ned-desktop:~$

Never mind. Should have used bash instead of dash (sh) to run script.

I have dual-boot Windows XP/Xubuntu 11.10 system. Installed CAVL no problem. Scanned Xubuntu partition no problem. Scanned Windows XP NTFS partition no problem. On Access correctly identified eicar.com when I tried to access it. At some point soon after this the following problem materialized:

cmdagent started using lots of CPU. Looks like it was trying to mount the Windows XP NTFS volume, which was already mounted. cmdagent and mount tasks were using 99% CPU. cmgdaemon was also using CPU although I had mail scanning turned off (I use Thunderbird for mail). Worked great while it lasted but CAVL is now useless because even on-demand scanning requires cmdagent, which leads to above condition when started.

Other problems/suggestions:

  1. “sudo /opt/COMODO/load_cmdagent.sh stop” will stop cmdagent but start and restart will not start it once stopped. Need to run diagnostics with fix option to get cmdagent running again.

  2. cmgdaemon runs when no supported mail program exists. I’m assuming that cmgdaemon is used only for mail scanning. It can be stopped but diagnostics with fix option will start it again. Need an option to not run the mail daemon. Diagnostics should recognizes this option so it won’t restart the mail daemon. Or, ideally, fix to work with Thunderbird.

  3. When cmdagent is running GPS, a GTK+ task manager that I use, starts but displays an empty window. Stop cmdagent and it works fine. This is a very old app (2002) but I have used it for years without a problem.

Two possible problems (rarely occurs):

  1. what is on the desktop does not appear (no Comodo icon or what is save on desktop - in 99% of cases log out resolve problem);
  2. system freezes when I try to restart or shut down (screen for restart / shut down appears and freezes);
    Can anyone confirm? Ubuntu 11.10 (32 bit) and Ubuntu 12.04 (64 bit) with AMD drivers. While I dont had AMD driver had no problems (but it is likely that the problem has not had time to appear ).

Ty much this is exactly what I needed for my small home business network. for anyone stuck Im running Ubuntu x64 oneiric 11.10 … ran the install, then opened terminal typed command “sudo /opt/COMODO/post_setup.sh” worked great. cheers

When start new version CAVL ?
This new version? 1.0.220659.32

Not quite sure what I’m doing wrong here as I’ve installed CAVL on 3 other computers previously (all working). However, this particular laptop has only 512mb ram (others have 1gb) so not sure if this is the issue or not.

Ran the script (basically pressing key to skip past all info and use default language) but then it just sits at the language selection prompt as if nothing has been selected. I’ve tried pressing 6 (default language) yet nothing seems to be happening. Have tried this a couple of times now without success :(.

Is it possible to jump to end of script (without having to keep key pressed down) so I can then select the language manually?

:slight_smile:

would this work on linux mint ? ???

should be fine with all Ubuntu based distributions