Comodo AntiTheft: Yahoo not accepted, SSL not a listed option

Tried to set up “TakePicture” for HTC Thunderbolt Android, get “Unable to connect to your SMTP server. Please enter valid SMTP port, server, username…”

Yahoo settings per yahoo:

SMTP server:
Port: 465
Use authentication

There is no option to set SSL in Anti-Theft that I can see. Without it any attempt to connect to the SMTP server will fail.

Also, in my experience, trying to send an email to myself in yahoo doesn’t work. A copy usually appears in the mail client’s sent folder, however email sent from one client does not appear in other client folders. If I really want to send it to myself, I usually have to send it myself on another email service.

Any suggestions. ???

CAT: V1.0.2221.2
also: Comodo mobile security V1.4.252863.8 CAT

Phone: Android version 2.3.6, HTC Sense version 3.0, Software number: 1.01.1520.0
Kernel Version #38
Baseband version,
Build number: ThunderStick Full Blown v1.1.1
Browser version WebKit/533.1

Since you are experiencing email issues with Yahoo to begin with, I would suggest another mail service (Gmail, Hotmail for example)

yahoo mail works with other android mail readers that provide an SSL option, just not with comodo anti-theft because yahoo wants a secure comnecton with SSL, but that is not a comodo anti-theft option. btw yahoo closed port 25 a long time ago as an anti-spam measure so comodo’s documentation is out of date.
earlier post has current options, but I suspect yahoo would rather have members refer to their help for this information.

Ok, I did some tests and found the solution. Port 465 is for secure ssl email. I changed the port to 587, used full in email address and account name fields having done the tick for verification and it works!

Please try this and let me know if it resolves your issue.