Comodo and the Terminal Service

Hi, I was just wondering why the firewall needs the terminal service to initiate. I was re-tweaking my services for XP and realised that the terminal service was enabled again, so I disabled it and rebooted then noticed that something was slowing the computer down a little bit, then checked the firewall and it was still initiating.

I left it a bit but it didn’t initiate so I reinabled the service and rebooted and all was fine again, I just feel a bit weary about leaving this service enabled or am I being paranoid.

Will this service still be needed for future versions?

Comodo without service: http://img117.imageshack.us/img117/6915/terminal1mk1.jpg

Comodo with service: http://img183.imageshack.us/img183/3254/97291740pd7.jpg

;D

EDIT: Oops should have searched the forums just found some posts on this sorry! I also have fast user switching disabled but that doesn’t affect the initiation speed one bit.

Terminal Services is not a pre-req for CFP. This problem has been around since V2 and it doesn’t look like development has been able to fix it 100% for everyone.

V2.3.5 - FIXED! Startup Delay if Terminal Services service is disabled
https://forums.comodo.com/empty-t2503.0.html;msg19366#msg19366

CPF Beta 3.0.10.238
https://forums.comodo.com/32_bit_bug_reports/cpf_3010238_beta_32bit_bug_reports-t14004.0.html;msg98951#msg98951

Al

I get the startup delay too, with that service disabled. (on 3.0.14.276)

I actually found out as late as yesterday, as I started to disable many services. It seems like the firewall works anyway, isn’t it just a GUI problem??

/LA

I disabled Terminal Services long before I installed CFP, so it takes some time to initialize (so it says), but really it’s up and running. So yes, it’s a GUI problem, since both the firewall and Defense+ works just fine.

Cheers,
Ragwing

Nice, I suppose that’s a confirmation. We can have the service disabled but CFP’s GUI needs it to start normally.

/LA

OT, but I would be interested to know what development toolkit Comodo is using for CFP.

Al

Thanks for the infos, I disabled the service then restarted and waited to see how long the GUI took to say the firewall was ready, waited a bit longer this time.

Also I did a quick port scan from my linux machine using nmap also loaded up a new program on XP to test Defence+ and that was ok. It took 4 minutes for the GUI to catch up, XP was a little bit slower in those 4 mins “not really that noticeable unless your fussy” than with the service enabled but afterwards all was smooth again :slight_smile:

Hope the dev’s sort this one out 100% and we get a proper fix (L)

Thanks for the testing & confirmation that it’s a GUI bug. I knew the fw was active during that stage, but wasn’t sure on D+.

No problem, Soyabeaner. :wink:

Just one more appeal that the Terminal Services bug in CFP be fixed! I am leaving the service at Manual, since it only takes a couple of minutes to get my system fully functional that way, against about four minutes longer with Terminal Services disabled.

Well unless you are actually running a terminal server with either thick or thin clients I recommend you disable this service.

Terminal Services sometimes can be enabled by Windows without the user’s consent. This shouldn’t come as a surprise since it’s a sneaky snake, but it doesn’t work for nLite’d systems like mine that have the service uninstalled :-\