Comodo and Outlook - Error 0x80042108

hi.

i’ve got some issues regarding outlook 2003 and CIS Firewall.

When we’re checking incoming e-mails, Outlook sends 0x80042108: “'Outlook is unable to connect to your incoming (POP3) e-mail server”.

Sometimes it happens, sometimes it doesn’t.

The problem is, they’ve only appeared when i started using comodo internet security on my company. I’ve checked all possibilities from microsoft support (Error occurs when you send or receive an email message in Outlook or Outlook Express - Microsoft Support)

You are not connected to the Internet or a network, or your mail server is temporarily unavailable.

  • i’ve phoned our e-mail service provider and it’s all good

Your account settings are incorrect.

  • we’ve got several accounts through several computers

Your user profile in Outlook is damaged.

  • i’ve checked, nothing wrong

An e-mail item on your POP3 server is damaged.

  • i’ve scanned for errors, nothing found

The configuration of your AV software is incorrect.

  • apparently nothing’s wrong, it’s on my trusted applications list

Outlook Express was removed from the computer or the installation is damaged.

  • i’ve got outlook 2003, and i’ve reinstalled. same problem

The configuration of your personal firewall software is incorrect.

  • i think it’s all well configured

thank you for your time

regards

The firewall rule I have with Outlook 2007 is Custom: Allow IP Out from IP Any to IP Any where Protocol is Any.
(CIS created this rule). I do not have any connection issues with it.

The Defense rule is also custom. Try removing the rule from Defense+, then rerunning Outlook. Allow and remember answer with the popup.

in firewall rules i got “Allow All Requests”

i’ve removed the ruke from defense+ too and i’ve got the popup. i’ve chosen the “trusted application” predefined policy

regards

Hi!

1,5 year. No solution?

With Comodo Firewall Pro 3.14 was not this problem. Now, CIS Comodo Internet Security 5, I have the same 0x80042108 error and can’t receive e-mails with Outlook 2003 - only if turning off firewall.

Solution?

(Edit later)
BTW, I can not see some Internet pages, too. But now I found the “solution” for this symptoms: turning off proactive mode. (After it you must turn on Sandbox again, if you use.)
But proactive mode is offered by Comodo! …

What policy are you using for Outlook? Do the firewall logs give a clue here? They are under View Firewall Events. Can you post a screenshot if you see things logged for Outlook?

Policy: tried both “enable all in and out” and “e-mail client”.
FW logs: in events nothing about Outlook. (CIS did not notify me about any restrictions)
Screenshot too long to do :slight_smile: +settings again… All of my incoming services gave an error message, something like “error 0x80042108, can not contact with server” (same, as at Maikkano, but in hungarian).

Now i got the problem , 0x80042108b worked me thru problem related item on microsoft about outlook , checked it , checked disk , checked virus/malware thouroughly and still problem , only when i exclude Comodo by disablebimng it in msconfig outlook works fine , but when i start up with it it’s a random “not working outlook” even switching off comodo dont help (think ccc always keep running).

What is altered ( i didn’t make any changes except updating ) ???

Which entry of CIS did you disable in msconfig? Cfp.exe or cmdagent.exe?

COuld you do the following for me? Temporarily disable the Firewall? Right click on the CIS icon in the systray and choose Firewall → Disabled. See if that solves the problem or not. Don’t forget to switch the firewall back on. It won’t remind you after a period of time.

Can you post screenshots of Global Rules and Application Rules? They can be found under Firewall → Network Security Policy. Could you also post a screenshot of the firewall logs (View Firewall Events)?

in msconfig (XP) i turned off CFP , then no single file is run ning from comodo , if i start it and switch it of (totally) always 1 file keeps running and don’t allow to be stopped ( atm don’t know which one , think ccc or cmdagent)

And my outlook problem is simple it has to be comodo (or an update on outlook that doesn’t like comodo)

atm very few time , make screenshot later

Ok. I will see when you post.

Don’t forget to test by temporarily disabling the firewall and see if that helps or not.