Comodo and Age of Empires 2

There is something wrong in Comodo Firewall. When I try play that
Comodo block it…it doesn’t help even I try allow it in application monitor or
component monitor!
Only way to play age… is Turn off all application monitor!

Did you try played any with Comodo?