Comodo add the same rule again and again at windows startup

hi,

i’m french.

I’m using an Xtreamer mediaplayer over my Lan.
Every time windows (XP) start Comodo alert me for an incoming connection from 192.168.0.30 (the Xtreamer) and every time i allow it.
So in the applications rules tab i had the same rule again and again in System.
It look like this :

System :
Allow TCP in from IP in [192.168.0.30/255.255.255.0] to Mac Any Where Source Port is Any and Destination Port is Any
Allow TCP in from IP in [192.168.0.30/255.255.255.0] to Mac Any Where Source Port is Any and Destination Port is Any
Allow TCP in from IP in [192.168.0.30/255.255.255.0] to Mac Any Where Source Port is Any and Destination Port is Any
Allow TCP in from IP in [192.168.0.30/255.255.255.0] to Mac Any Where Source Port is Any and Destination Port is Any
…etc.

I don’t know if it is a bug, but i don’t understand why comodo ask for a rule already present.

thanks.

As it is incoming you have to create a Global rule if you want to allow this connection.

Dennis

Thks,

i’ll try this.

++

I don’t think you are right, Dennis2: if no global rule overcomes, an incoming application rule should work.

A good occasion to say that, in my opinion, every global rule excepting ICMP ones is useless and source of trouble.

I am very dumb with all of media devices, and i thus don’t formally know what drs is speaking about; but if his media speaker is a removable device, it would also be an issue for rules not being remembered for it unless he can make it seen as “fixed” by some utility (like Hitachi Microdrive filter).

We assume of course that the stated rules were not only allowed, but also remembered…

“Allow TCP in from IP in”<—?

at brucine: the global rule “block all incoming, and log”, is very usefull, as many people would not ask here if they should allow something they have no idea about where it comes from… just because its asking so nice to come in :wink:
and the log tells you, if something was blocked right when you started it.

I dont know if this a correct topic,

Im using Comodo Firewall only 5.0 1135
and avast antivirus
malwarebytes (on demand)

But suddenly comodo cant remember all my allowed application including the one that already trusted
Like avast, firefox, thunderbird, and all application,

it keep display the pop up warning that, this application want to access bla bla, the application want to connect to bla bla… even when i already set it as trusted application and set it to remember my rules. restarting the computer still the same.

Installed for a month and not changing any setting whatsoever. tried to scan the drive with avast, and eset online scanner and no infection.

thanks

da_man
make your own topic, as otherwise the line of argumentation for this case will get broken. here it is about internet “connection”.

in your topic dont forget to specify your settings of comodo.

hi,

after some time of tests there’s no change with a global rules.

After each reboot Comodo alert me for an incoming TCP connection from 192.168.0.30 on port ms-ds (445)

++

Make your local network or your mediacenter a trusted zone using the Stealth Ports Wizard. Following is a mini tutorial.
First look up your IP address and subnet mask. In Windows go to Start → Run → cmd → enter → ipconfig → enter → now lookup your IP address and subnet mask.

Second create a zone in My Network Zones (Firewall → Network Security policy). Choose Add → A New Network Zone → fill in a name like My local network → Apply. Now select My Local Network Zone → Add → A new address → choose An IP Address Mask → fill in your local IP something like 192.168.1.x usually and your subnet mask; usually 255.255.255.0 → Apply. Now check and see the new network defined. Exit using Apply.

Now we are going to use the Stealth Ports Wizard to make your local network a trusted network:
Choose “Define a new trusted network and stealth my ports to EVERYONE else” → Next → choose “I would like to trust an existing My Network Zone” → choose your local network zone from the drop down box at the bottom → Finish.

Now check your Global Rules and see your network added.

hi,

my local network is already in trust zone : system.exe and globals rules are set to allow ask in and out in this local network.
I have try to set another trust zone with single IP, IP+Mask, IP range or Mac adress.
Same results :frowning:

thks.

valid rules are “read and followed” from top to down of the lists.
make sure that the rule order is right.

when you have a rule on top of all rules in global rules, which says: “block ingoing IP (protocolls) from any adresses any ports”, you should not get this ingoing question again.
if you need few exceptions put them over this rule.