Comodo 4 and MSN Live on windows 7

Well, im not sure but im like 90% sure this is a D+ problem.

On my x64 system when i turn compatibility mode (windows vista) to MSN Messenger it should go to tray (notification area) when minimized, but it doesnt :S (if i unistall comodo it works fine). Also if i KILL cmdagent.exe and cfp.exe (aka no COMODO) it wont work, only works if i unistall.

Is there any way to fix it ?

Having same problem here, the Vista compatibility trick just won’t help any more.

What about some support please ?

It seems to be working here on Win 32 bits. Minimizing will go to the task bar, closing will go to the tray.

LDK: what OS are you on?

Having the exact same problem on windows 7x64. Uninstalled CIS until a solution is made.

yes, confirming this too. I noticed that just after installing CIS4 earlier today. Should be Def+ related…but no idea what exactly; hoping that won’t prevent other programs that wouldn’t run other than in compatibility mode to run on… W7/64 here.

Seem like W7 - 64bit is the culprit ^_^.

There an addon call MessengerDiscovery, in v2.5 you can send it to tray however it still in Beta XD

I get the same thing in W7 x64. Also if using compatibility mode, MSG Plus ( no longer works.

I have Defense+ and Sandbox disabled.

I figured out how to get it to work! You must turn into compatibility mode(xp or vista works too), but you must run it from the original folder(C:\Program files\Windows Live\Messenger\msnmsgr.exe) and it will work. When you run it from the lnk it wont work. I started it from a Commander(Total Commander Ultima Prime 5.0, not from Windows explorer). Sorry for the bad English.


Tried it. Did not work.

Then I have no idea. I tried it and it is working. Here is the proof:

I tried with no success either :\ ■■■■… im about to uninstall comodo’s firewall because of it

Installed new comodo in home and office.

At office the msn works fine, but doesn’t go to notification area.
At home it’s go to the notification area, but I have to disable both Defense+ and Sand Box to get it connected - after connected I can enable then back (that’s not the firewall, it’s something else).

Both pcs are running on Windows 7 64bits ultimate and are updated to windows-update.

Updated, now Comodo & MSN are friends again in home, but in office… I’m having to deal with two MSN bars :frowning: (Yes, I prefer the old task-style, I hate icons without labels)

So it an unfixable problem huh? I like the constant comodo 4 virus database updated, the staff must have been working hard.

Lucky for you sunshine there are two topics about this in the bug board. That means the devs have seen it. Give them time. Not quite a show stopper bug by the way… :wink:

Well it’s enough to make me uninstall CIS. It’s blocking all programs from using compatibility mode. That renders some programs I use useless. So until it’s fixed, myself along with quite a few others will be staying away from Comodo.

Same thing here, perhaps they’ve been working on this, but this is definitely enough to make me uninstall CIS, too. I’ve tried both CIS and CFW with no luck (although they look exactly the same one way or another), and pretty much my favorite online game needs to be ran under compatibility mode! That is the most unacceptable part.

By the way I only installed the firewall, that means D+ is disable permanently, and this still happens. So one way on another, its either going to be “permanenetly disable D+ function is kidding me”, or “it is not D+ business at all”.

You can probably rename guard32.dll (in system32) and reboot. Leave most of D+ intact. Please say if this solves the problem.

Also you can probably run it using ‘Run a program from the sandbox’ (NOT Add a program).

Best wishes