Comodo 3.9 and a BSOD loop

Good day fellow users. I seem to have gotten into another mess and unsure of what may be the cause this time. I would like to say that I have no form of documentation on the matter, but as it happens I decided the best way to resolve my issue would be to wipe the drive. It should be no surprise that I am fairly afraid of Comodo at the very least. I’m using AVG for the time being, but I love Comodo so much that I’d like to give it another chance.
Now to begin the actual rundown of what happened; I received the usual “Updates have been found” notice box and clicked to have it download and install. It seemed to freeze for a while, so I decided to take off my internet intensive programs and allow it to utilize the full connection. After a while or so, I got the “Comodo needs to be restarted for updates to take effect” window and I was more or less satisfied that it had updated. I chose to restart immediately as I always do. Upon restarting, my computer booted up but froze at the Logon Screen. After a couple of seconds it restarted all on it’s own accord. This time the logon screen came up fine and I logged into my account. I was a bit confused as to what could have happened, but I took no worry about it. After a couple of minutes of normal use, I got the “Updates have been found” window again from Comodo and although I was a bit puzzled, I rationalized to myself that it could be some sort of supplementary update. I allowed it to download and install however, this time it literally froze for at least 6+ hours with absolutely no progress (or even any sign of still active). I opened up the Comodo Main window to see if there was any “cancel” button to say the least. That’s when the problems really began, Comodo froze. I restarted my computer, having windows force Comodo to shut down. I then proceeded to download the newest setup files from the Comodo website, I noted that the version number was “3.9.76924.507” After downloading, I unplugged my connection and uninstalled the version I was using. I restarted and proceeded to immediately install the newer version. Everything seemed like it worked just fine until reboot. I got an error in the Comodo Main window ( I don’t remember the exact words but it was somewhere along the lines of “Comodo failed to initialize”) and all hell began to break loose. I checked my internet connection and although my router professed that it was connected and working perfectly fine. ( I even tested it against my Console machine and it worked just fine there.) My computer, refused blatantly to even acknowledge that I had a Network Interface Device installed. I watched through my Device Drivers and found it there, with no errors but on the actual “Networking and Internet” control panel I got no Network. I decided that it may have been a problem with Comodo, so I uninstalled and reinstalled again to get the same results. I rebooted the computer one more time, expecting to go into safemode this time. I got a BSOD on the driver loading. It ran by too fast for me to even read anything. I have my BSODs set to only reboot when I press a button. It wouldn’t even flash for less than a second. Then it started in a loop of Restart > Load > BSOD. Both in normal startup and safemode. So cursing and probably ranting a bit, I decided on the course of action that had me wipe my drive and reinstall vista. On my fresh installation, my internet connection worked instantly (as it usually does) and I’ve so far been afraid to reinstall Comodo.
I’ve backed up a number of files, I usually back them up the second I make / download them. There are some important files, that weren’t backed up however, that are probably going to set me back a bit. Nothing I can’t redo thankfully. I pity that a situation as this one could not be resolved without needing to go this far. I understand that these things happen though so no hard feelings of course. I’d just like to have someone more experienced in the matter reassure me that it was probably just a fluke, or maybe some bad timing (for with Windows Vista you never know what its updating and when) or even luck of the draw. If it is a problem with Comodo, then I’d be more than happy to wait for the next fix.

My computer is
AMD Athlon x64 5200

My network device is
NVIDIA nForce Networking Controller

My Operating System is
Windows Vista Ultimate x86 (or x32)

Any further information needed, please feel free to request it.

I am very sorry to hear you got in this uncontrollable loop. I don’t recall having seen this type of behaviour. Usually CIS should work fine with Windows Vista 32 bits.

Meanwhile CIS has been updated to 3.9.x.y.509. The only change for the 509 was:

Edit: 509 addresses system freezes and BSODs some users may be experiencing. You do not need to reinstall anything. Automatic update will do this simple update for you.
You can get it here: .

I am not sure what scenario you triggered but installing it again should most likely go fine.

Did you have any other security programs installed and which one(s) were running in the background? Nvidia based network controller come or used to come with a firewall which, when switched on, is known to cause conflicts with other firewall or security programs.

please try this version 32bit 64bit

For reference, I have the exact same problem described here:;msg287691#msg287691

There are other users who have the same problem, relevant threads are referenced on the post above. My crash dump is also available a few posts prior on the same thread.

Hello Mr Go,

Can you please post what other security software you have installed on your system ?
Does not matter if it’s real-time or on demand.

Can you also post your BSOD minidump here:

You can find more minidump info here: