Comodo 3.10.101801.529 and VideoReDo

The latest Comodo Firewall update has stopped VideoReDo and Steam applications from working. I am using Vista Home Premium fully updated and SP2. When I double click on either of these application they simply say “VideoReDo (or Steam) has stopped working”.

Uninstalling Comodo Firewall fixes the problem.

Is your Windows Firewall running? CIS does not disable when installing.

Please update CIS to the latest version, .531, and see if that helps.

I have checked the Security Centre and the Vista Firewall is off and Comodo is on. The Comodo working version I am currently usimg is 3.8.65951.477. I tried VideoReDo and it is working fine.

I invoked a Comodo update and ended up with version 3.10.102363.531 installed. After rebooting I checked the Security Centre again. Windows Firewall was off and Comodo on. I tried VideoReDo and it errored immediately with “VideoReDo.exe has stopped working” as before.

Again I uninstalled Comodo and rebooted the machine. Obviously I now had to turn on the Windows Firewall. When tried again, VideoReDo worked fine.

It would be interesting to know whether it is related to Firewall or D+. The reason I ask I think it may be a bug and I want to get a bit closer to what part of CIS is causing this.

Are you willing to try another install of CIS?

First thing to try is to disable the Firewall: right click on the CIS icon in the systray → Firewall security Settings → set to disabled.

Then temporarily disable D+: Defense + → ADvanced → Defense + settings → now tick “Permanently disable defense + (requires a reboot)” → reboot when asked.

Keep us posted.

The current installed version of Comodo is 477 with which I have no problems. Right clicking on the Comodo icon on the system tray show Defense + Security Level as disabled and Firewall security Level as Safe Mode. VideoReDo works.

Again I invoked an update and 531 was installed. The settings as stated above were still valid. VideoReDo had stopped working. I checked the Defense + → Advanced → Defense + settings → and Deactivate Defense+ Permanenbly was already ticked.

I then changed the Firewall Security Level setting (via icon on system tray) to Disabled and rebooted the machine. Obviously Windows warned me of the lack of security.

VideoReDo still doesn’t work. Uninstalling Comodo and rebooting restored VideoReDo to a working mode. I should mention that I have contacted VideoReDo support and they have already had reports the Comodo and possible Vista SP2 had a problem which could be resolved by uninstalling Comodo (which is does). I am not alone with the problem!

Hope this all helps.

Your topic is in the right board so the devs will see this.

Not sure if this helps but I can confirm that the same combination running on Windows XP Pro is ok. In other words, Comodo 531 running on Windows XP Pro does not interfere with VideoReDo which continues to run ok.


first of all thx to the Comod team for such a great product! :comodo110:

Ok, I must say that I have the same similar problem. I have:
Vista Basic
Comodo Version 3.10.102363.531
Video redo: 3.14.594 (althought the version 2 also gives me the problem)
It just crashes, telling me that there is a problem and it has to shut the program
Hopefully you guys can solve the problem as fast as possible. I need Videoredo :wink:
If there is anything I can help in testing, just tell me (I will check the board several times a day until it is resolved)



Same problem here using Vista Home Premium. I’ve had to remove Comodo pending a fix as I use Videoredo daily.

I havn’t used Videoredo for about 6 months. I tried to use it on the weekend and got the same error. I am running Windows Vista Home Premium SP2 and have Comodo firewall 3.11.108364.552.
Has there been any resolution to this problem ?

same problem for me. I was using videoredo last week but since then Ive installed Vista SP2 , maybe thats the cause because I had no problems before that.
Running Comodo version 3.11.108364.552 and lastest Videoredo , no worky!!, crashes immediately on start.

I use Videoredo all the time and so need a Comodo fix quickly .

Any news on when this will be?

Same problem here. Any fixes yet?


I have the same problem with Mobiola Video Studio and Comodo. My thread is right before this one. Hopefully a fix is coming. I prefer Comodo over Outpost that I now have in order to use Mobiola. I also have Vista Home Premium SP2/Nod32.


Happy to report that this problem appears to have been sorted wioth the latest Comodo release.


I’ve just reinstalled comodo.

I un installed a few weeks ago, having come up against this problem with videoredo not

I’ve updated now to 3.13.121240.574 & videoredo still does not work.

I’m using Vista by the way.

Anyone got any ideas?

Below is my post from the Bugs forum, solved my Mobiola issue similar to this one.

Unfortunately Comodo is still messing with NOD32, so I went to OnLine Armor which, so far, is fast and very light with no conflicts. Crossing my fingers. Will come back to Comodo when the conflict issue is resolved.

“Try excluding Kindle in the Image Execution Control Settings under D+. It worked for me when having a program as trusted didn’t work. Assuming you are 100% comfortable with the program as a safe one.”


Yeah, thanks rugmankc.

would you believe I read how you sorted your problems about 30 seconds after uninstalling comodo
so I could use videoredo.

I reinstall it and try.


Hope it works :slight_smile: