Comodo 3.018 not blocking anything

Hi all,

I am using the latest version of Comodo v3 (.18) but am having a major problem. On a fresh install of Vista x64, the firewall module does not work properly - I have set it to custom policy, so it should prompt for all outgoing requests - but it just allows everything to connect!? I have tried installing firewall only and with Defense+ to no avail.

The block all mode works still. I swear on older versions it had a ‘block all outgoing requests’ rule in the global rules??

Then when uninstalling, it bluescreens as the driver is not disabled before uninstalling? I thought the beta had ended!!



Why do you need custom mode? I have Comodo at default settings from install. Firewall is at Train with Safe Mode and D+ is on Clean PC Mode. What programs arent you getting alerts for? If they are common programs like IE or FF thats normal cause those are white listed by Comodo. Comodo has a very big white list now.

I like to block anything that doesn’t need internet access as I have a limited amount of data. The custom policy has no application rules, the only global one is ECHO REQUEST. Literally all programs are allowed access, even LeakTest.exe for example.

The other thing is that the animation of up/downloading on the taskbar icon doesnt work, nor is any traffic shown in the main window whilst browsing etc.

What version are you using? Try doing a complete uninstall and reinstall using Revo Uninstaller in Advanced mode. I leave Comodo on the settings it installs with and everything works fine. I shut off the traffic monitor cause I dont care to see flashing lights. I can also get Comodo to pass all leak tests. GRC Leak test, PC Flank test and the System Shutdown Simulator. Do you have D+ active?

I am running 3.018 but it was a clean installation - funnily enough Revo cannot detect the installation! I have tried D+ on and off.

Revo is only an uninstaller. Is it not in the list? Is it in your add/remove programs? You still havent told me what programs you want alearts from. See with 2.4 people where getting to many alert for every program they used. So now with 3.0 and a huge white list the alerts have been alot less making the firewall more user friendly. Try downlaoding a program that is not usually white listed. Set your firewall to train with safe mode and D+ to Clean PC Mode.

You may need to do this.

Hi James,

Make sure on “summary” tab there is big green checkmark and line “all systems are active and running”. Run diagnostics under “miscellaneous” tab.
Check this options: firewall->advanced->firewall behavior settings->alert settings->alerts for all protocols are enabled;
miscellaneous->settings->parental control->“suppress” options are not checked.

Thanks for your replies.

I have tried a clean installation to no avail, same thing. I want to block Money, games etc, which may be on the safe list but custom overrides this, as they have no app. profiles yet - i have checked to confirm this.

Summary has a green tick, diag found no problems and no supression is enabled.

When browsing however, no inbound or outbound connections are shown.

I am also using AntiVir.

I think the cause is Microsoft NetMonitor 3.0 - I uninstalled loads of software to see if it was an incompatibility, and think this is the culprit. Took a reinstalll afterwards to restore comodo to working, but that could be the cause.

The installer is buggy tho, I selected Firewall ONLY, yet still got inundated with Defense+ Popups, it hadn’t been disabled.

Ok, thanks for research :-TU
If you’ll find out that NetMonitor is the reason of that issue for sure, let us know please.
Also, is 3.0 latest version of Microsoft NetMonitor? If no, please check whether Comodo Firewall 3.0.18 has same issue with latest version of NetMonitor.