Comodo 3.0 doesn't recognize Thunderbird Portable

I have Thunderbird Portable on a Flash drive. I have tried accepting it as:

a web browser
an Email client
a safe application

I have replied “allow” many, many times when Comodo pops up when Thunderbird
starts up.

It still insists that Thunderbird.exe is unrecognized.

Any suggestions?


I have the exact same problem. I set up comprehensive predefined rules for this application, made sure it is not running from an alternate location and triple checked everything else. There is no reason this should happen and its the only piece of portable software I have (which I pretty much ONLY use portable software even on my HDD) that this happens with.

Comodo does not apply rules for applications on removable drives,

That doesn’t explain why it still happens with the portable thunderbird I have running from a HDD on one of my other machines. (Before you ask why, “portabilizing” apps keeps windows cruft-factor to a minimum)

Maybe it would be best for a comodo official to post on this, I believe it has something to do with the drive not existing when you remove it.

That was my original guess until I tried it out running from my Apps drive (a partition on my main HDD that I keep all my portable apps on) and had the same issues. That drive is NEVER removed from the system.

My guess is it has something to do with how portable thunderbird is made portable (temp faking registry entries or system files) so it is probably NOT a Comodo issue, but it could be an incompatibility that might be worth looking into.